Page MenuHomePhabricator

Invalid property name throws an error
Closed, ResolvedPublic

Description

When I use an invalid property name such as $wgBannerProperty="", WikidataPageBanner throws an error as https://phabricator.wikimedia.org/P1067
Expected behaviour should be to add no wikidata banner on the article.

Details

Related Gerrit Patches:
mediawiki/extensions/WikidataPageBanner : masterWikidataPageBanner check for invalid Property name

Event Timeline

Sumit created this task.Jul 27 2015, 2:53 AM
Sumit raised the priority of this task from to Needs Triage.
Sumit updated the task description. (Show Details)
Sumit added a project: Wikidata-Page-Banner.
Sumit moved this task to June 26-July 18 on the Wikidata-Page-Banner board.
Sumit added subscribers: Sumit, Jdlrobson.
Restricted Application added a project: Wikidata. · View Herald TranscriptJul 27 2015, 2:53 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 227176 had a related patch set uploaded (by Sumit):
WikidataPageBanner check for invalid Property name

https://gerrit.wikimedia.org/r/227176

Oh I see... so this was an existing bug.
(The reason this is problematic is the first experience a user who has newly installed this extension has is it exploding in their face!) Thanks for clarifying it's an existing bug.

Change 227176 merged by jenkins-bot:
WikidataPageBanner check for invalid Property name

https://gerrit.wikimedia.org/r/227176

Sumit closed this task as Resolved.Jul 29 2015, 1:38 AM
Sumit set Security to None.