Page MenuHomePhabricator

Middle clicking coordinates doesn't open a new tab
Closed, ResolvedPublic

Description

I middle click coordinate links a lot on Wikipedia articles to open them in a new background tab. Today I noticed that it doesn't work properly in some Wikipedias (e.g. English, German), instead it reacts like a left click and loads in the current tab. It works fine in other Wikipedias (e.g. French, Spanish).

e.g. Try to middle click the coordinates in the top right on https://en.wikipedia.org/wiki/Berlin and it loads in the same tab. Do the same on https://fr.wikipedia.org/wiki/Berlin and it opens a new tab.

It only seems to affect WebKit/Blink-based browsers (both old and new). It works as expected for me in Firefox 37, Firefox 24 and Opera 12, but not in Chromium 43, Chromium 33, Safari 5.1 or Vivaldi TP4.

I have no idea which projects this belongs under, sorry, but since it's happening on multiple sites I presume it's not something the local wikis did and have therefore reported it here. :)

Details

Related Gerrit Patches:
mediawiki/extensions/WikimediaEvents : masterFix middle button check
mediawiki/extensions/WikimediaEvents : wmf/1.26wmf17Restore the ability to open GeoHack in a new tab
mediawiki/extensions/WikimediaEvents : wmf/1.26wmf16Restore the ability to open GeoHack in a new tab
mediawiki/extensions/WikimediaEvents : masterRestore the ability to open GeoHack in a new tab

Event Timeline

Nikki created this task.Jul 29 2015, 2:34 AM
Nikki raised the priority of this task from to Needs Triage.
Nikki updated the task description. (Show Details)
Nikki added a subscriber: Nikki.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2015, 2:34 AM

I can confirm this but I don't think this is a problem with Wikimedia code. See for example bug reports like https://code.google.com/p/chromium/issues/detail?id=255 or https://code.google.com/p/chromium/issues/detail?id=34691 which might be related.

Have you reported this problem to (for example) Google's bug tracker for Chrome?

Aklapper renamed this task from Middle clicking coordinates doesn't open a new tab in some Wikipedias to Middle clicking coordinates doesn't open a new tab in Chrome.Jul 30 2015, 12:17 PM
Aklapper set Security to None.
Nikki added a comment.Jul 30 2015, 2:02 PM

I haven't reported it anywhere else, no. Is there any point if it's been known since 2008? :/

Even if the bug is in WebKit (and everything based on it), couldn't the Wikimedia code still be changed to avoid triggering the bug? Clicking the link on the English page follows it like an ordinary link (so I have no idea what the "click" event handlers are doing), there's already an example of code which doesn't trigger it on the French page, and if I run $("#coordinates a.external").unbind("click"); in the console on the English page, I don't even see any difference in behaviour afterwards, except that middle clicking is possible again.

Aklapper renamed this task from Middle clicking coordinates doesn't open a new tab in Chrome to Middle clicking coordinates doesn't open a new tab.Aug 4 2015, 7:03 AM

I'm getting afraid this is triggered by T103017: Use EventLogging to track geo feature usage actually...

Confirming behaviour for Firefox 39.0.

MaxSem claimed this task.Aug 4 2015, 6:49 PM
MaxSem added a project: Maps-Sprint.
MaxSem moved this task from Backlog to In progress on the Maps-Sprint board.

Change 229205 had a related patch set uploaded (by MaxSem):
Restore the ability to open GeoHack in a new tab

https://gerrit.wikimedia.org/r/229205

MaxSem moved this task from In progress to Needs review on the Maps-Sprint board.Aug 4 2015, 8:32 PM

Change 229205 merged by jenkins-bot:
Restore the ability to open GeoHack in a new tab

https://gerrit.wikimedia.org/r/229205

Change 229283 had a related patch set uploaded (by MaxSem):
Restore the ability to open GeoHack in a new tab

https://gerrit.wikimedia.org/r/229283

Change 229284 had a related patch set uploaded (by MaxSem):
Restore the ability to open GeoHack in a new tab

https://gerrit.wikimedia.org/r/229284

Change 229283 merged by jenkins-bot:
Restore the ability to open GeoHack in a new tab

https://gerrit.wikimedia.org/r/229283

Change 229284 merged by jenkins-bot:
Restore the ability to open GeoHack in a new tab

https://gerrit.wikimedia.org/r/229284

MaxSem closed this task as Resolved.Aug 5 2015, 12:04 AM
MaxSem moved this task from Needs review to Done on the Maps-Sprint board.

Same problem now with IE11.

Change 231608 had a related patch set uploaded (by MaxSem):
Fix middle button check

https://gerrit.wikimedia.org/r/231608

MaxSem reopened this task as Open.Aug 14 2015, 6:38 PM
MaxSem moved this task from Done to Needs review on the Maps-Sprint board.

Change 231608 merged by jenkins-bot:
Fix middle button check

https://gerrit.wikimedia.org/r/231608

MaxSem closed this task as Resolved.Aug 19 2015, 8:53 PM
MaxSem moved this task from Needs review to Done on the Maps-Sprint board.
Yurik added a project: Maps.Nov 7 2015, 7:34 AM
Restricted Application added a project: Discovery. · View Herald TranscriptNov 7 2015, 7:34 AM
Restricted Application added a subscriber: StudiesWorld. · View Herald Transcript