Page MenuHomePhabricator

Flow loading overlay does not disappear after load
Closed, InvalidPublic

Description

When I go to a Flow-enabled Talk page I see the loading cursor (cursor: wait;) indefinately and the overlay never goes away (flow-ui-load-overlay). If I go into my browser's inspector I can set flow-ui-load-overlay to hidden and continue to use Flow.

I should point out that even hacking around to 'use' flow shows that it doesn't appear to be talking to Parsoid. I don't see the mini-VE editor at all.

I'm running the master of both MW and Flow. VisualEditor is working as intended. Parsoid is parsing pages. Memcache is memcaching.

My Flow config is as follows:

#Enable Flow
require_once "$IP/extensions/Flow/Flow.php";
$wgFlowOccupyNamespaces = array( NS_TALK, NS_USER_TALK );
$wgFlowContentFormat = 'html';

$wgFlowEditorList = array( 'visualeditor', 'none' );
$wgFlowParsoidURL = 'http://localhost:8000';
$wgFlowParsoidPrefix = 'mercywiki';
$wgFlowCacheVersion = '8.7';

$wgDefaultUserOptions['echo-subscriptions-web-flow-discussion'] = true;
$wgDefaultUserOptions['echo-subscriptions-email-flow-discussion'] = true;

Event Timeline

Ckoerner created this task.Jul 31 2015, 4:25 PM
Ckoerner raised the priority of this task from to Needs Triage.
Ckoerner updated the task description. (Show Details)
Ckoerner added a subscriber: Ckoerner.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 31 2015, 4:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Do you get a JavaScript error in your browser console?

Catrope triaged this task as Normal priority.Aug 5 2015, 11:56 PM
Ckoerner added a comment.EditedAug 6 2015, 8:13 PM

Ah, yes. That might be helpful. Here's what I'm seeing at the moment. However, it looks like this isn't related to Flow. I disabled the HeaderTabs extension and it went away.

Mattflaschen-WMF closed this task as Invalid.Sep 6 2015, 2:14 AM
Mattflaschen-WMF claimed this task.