Page MenuHomePhabricator

flickrapi 2.1.1 and 2.0.1 do not support Python 2.6
Closed, ResolvedPublic

Description

The flickrapi 2.1.1 and 2.0.1 setup.py exits with

Sorry, Python 2.7, or 3.3 or newer required

While v2.0.0 may have been installable/usable on Python 2.6, this change effectively means v2 will not support Python 2.6

Details

Related Gerrit Patches:

Event Timeline

jayvdb created this task.Aug 4 2015, 1:33 AM
jayvdb raised the priority of this task from to Needs Triage.
jayvdb updated the task description. (Show Details)
jayvdb added a subscriber: jayvdb.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 4 2015, 1:33 AM
jayvdb renamed this task from flickrapi 2.1.1 does not support Python 2.6 to flickrapi 2.1.1 and 2.0.1 do not support Python 2.6.Aug 4 2015, 3:36 AM
jayvdb updated the task description. (Show Details)
jayvdb set Security to None.

Change 229071 had a related patch set uploaded (by John Vandenberg):
flickrapi v2 not usable on Python 2.6

https://gerrit.wikimedia.org/r/229071

Change 229071 merged by jenkins-bot:
flickrapi v2 not usable on Python 2.6

https://gerrit.wikimedia.org/r/229071

jayvdb added a comment.Sep 8 2015, 9:48 PM

This needs to be backported to 2.0 branch, as it is causing builds to fail.

If we agree on T114464: Pywikibot 2.0 should be Python 2.7, 3.3 and 3.4 only, this doesnt need to be backported.

jayvdb closed this task as Resolved.Oct 8 2015, 8:44 AM
jayvdb claimed this task.

We've decided to not support Python 2.6 with the Pywikibot 2.0 branch, so this isnt needed on that branch.

Restricted Application added a subscriber: pywikibot-bugs-list. · View Herald TranscriptDec 10 2017, 8:55 PM