Page MenuHomePhabricator

Add support for mp3 uploads and audio transcoding to mp3 and ogg.
Closed, DuplicatePublic

Description

Hi could the extension add support for mp3 uploads and audio transcoding to mp3 and ogg. it is off by default until mp3 patents expire in 2012.

The patent has expired and has been 3 years since it has expired there should be support for it now.

Event Timeline

Paladox created this task.Aug 7 2015, 12:19 PM
Paladox raised the priority of this task from to Needs Triage.
Paladox updated the task description. (Show Details)
Paladox added a project: TimedMediaHandler.
Paladox added subscribers: Paladox, brion, Bawolff, TheDJ.
Restricted Application added a project: Multimedia. · View Herald TranscriptAug 7 2015, 12:19 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Restricted Application added a subscriber: Matanya. · View Herald TranscriptAug 7 2015, 12:19 PM
TheDJ added a comment.Aug 7 2015, 12:35 PM

That's not entirely correct.

That was the expiration date of the most important patent. But for all patents to expire in the US, we would have to wait for 2017. I'm not sure about the rest of the world...

What happened if we do support would be disable it by default and put a message like It is currently illegal to use it in the USA but it is not illegal to use it in Europe.

Jdforrester-WMF triaged this task as Low priority.Sep 4 2015, 6:55 PM
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:59 PM
brion closed this task as a duplicate of T115170: Add support for MP3.Oct 23 2015, 7:55 PM