Page MenuHomePhabricator

ERR_SPDY_PROTOCOL_ERROR on Commons files with Chrome and Avast
Closed, DuplicatePublic

Description

On Google Chrome 44, the thumbnail is missing at https://commons.wikimedia.org/wiki/File:Continental_models-eo.gif and when clicked the image, it outputs ERR_SPDY_PROTOCOL_ERROR.

Event Timeline

Friendly_Seven raised the priority of this task from to Needs Triage.
Friendly_Seven updated the task description. (Show Details)
Friendly_Seven added a project: Commons.
Friendly_Seven added a subscriber: Friendly_Seven.
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald TranscriptAug 8 2015, 8:26 AM
zhuyifei1999 moved this task from Incoming to Backlog on the Commons board.Aug 9 2015, 8:13 AM
zhuyifei1999 added a subscriber: zhuyifei1999.

Works for me on Google Chrome 43

Can anyone else reproduce this?

@Friendly_Seven: Can this be reproduced only with that specific image? Or also with other GIF images? Or with other types of images? Links to more testcases welcome...

RobinHood70 added a subscriber: RobinHood70.EditedSep 11 2015, 12:41 AM

I'm getting this error repeatedly on mediawiki.org. Nothing loads at all on most attempts, and gives the above error. Sometimes, I'll get the requested page, but with no CSS at all. So far, I'm not getting the error on any other site, including the original Commons link. Exiting and restarting the browser *might* help, but that might just be a fluke.

Unlike the OP, this just started for me today or yesterday. A couple of days ago, the site was fine.

I'm using Chrome 45 on Windows 10, so it's possible this is some intermittent incompatibility introduced with Chrome 44.

Looking around some more, it seems not to be a MediaWiki specific issue at all. This reddit thread gives some insight. https://www.reddit.com/r/chrome/comments/3j1oqk/beta_or_canary_users_have_versions_later_than_44/

Given that disabling Avast temporarily seems to fix the problem, I believe it's most likely an incompatibility between Avast and Chrome, introduced in Chrome 44, and for whatever reason, mediawiki.org appears to be prone to triggering it, much like reddit is.

Aklapper renamed this task from ERR_SPDY_PROTOCOL_ERROR on Commons files to ERR_SPDY_PROTOCOL_ERROR on Commons files with Chrome and Avast.Sep 11 2015, 12:34 PM
Aklapper closed this task as Declined.
Aklapper set Security to None.

Thanks for finding out! I've updated the task description and closed this as declined as fixing seems to be out of control of Wikimedia.

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 4 2015, 11:52 AM
Tgr added a subscriber: Tgr.Nov 30 2015, 11:23 PM

ERR_SPDY_PROTOCOL_ERROR is a very generic error message that basically means something went wrong with the communication with the web server while using SPDY o HTTP/2. That could be a browser bug, an Apache or Varnish bug, a web server configuration problem, whatever.

If the error still occurs and you can reproduce it with some reliability, I think the way forward is to log the network details as described here and file a bug with those details attached against the Chromium project; they can at least figure out what the exact protocol problem is.

Mistake code err_spdy_protocol_error may likewise emerge because of some issue in your antivirus. On the off chance that you are utilizing Avast Antivirus on your gadget then you can include the address of the site which is giving this mistake to the execution rundown of Avast Antivirus. Avast antivirus helps in settling this issue just by overlooking the pages which are demonstrating this mistake. For settling this mistake with the assistance of Avast Antivirus you can simply take after the means given underneath:https://errspdyprotocolerror.com/