Page MenuHomePhabricator

Hovercards needs to be fixed for chrome on windows
Closed, ResolvedPublic

Description

Text overlaps the timestamp and settings button.

Event Timeline

Vibhabamba updated the task description. (Show Details)
Vibhabamba raised the priority of this task from to Needs Triage.
Vibhabamba assigned this task to pizzzacat.
Vibhabamba added a project: Page-Previews.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2015, 5:49 PM

@Vibhabamba, please add examples and steps to reproduce.

Here are the screen shots from the testing I did last week on Windows. I tested how Hovercards behaved in Chrome, IE and Firefox.

tldr: In IE, the first time I hover on a link, the Hovercard pops up correctly. The second time, it does not display properly. It will either show only the top part (no card - see the pink boxes in the screenshot - hard to spot), or will show the card, but the card won't be formatted properly. In Chrome we see this problem as well - sometimes the box is completely empty, sometimes only the photo is missing. Unclear if this is a loading issue (connection?) or an actual Hovercards issue.

I tested how Hovercards behaved in Chrome, IE and Firefox.

Which versions?

In IE, the first time I hover on a link, the Hovercard pops up correctly. The second time, it does not display properly.

Looks like T68496: IE (9, 10 and 11) compatibility: Card does not show on 2nd hover of same link; Images are not displayed.

See also T97901, T97918.

I will have to go back and check on the versions tomorrow when I have the Windows machine.

thanks for the links.

Jdlrobson triaged this task as Normal priority.Sep 23 2015, 7:01 PM
Jdlrobson added a subscriber: Jdlrobson.

@pizzzacat can you check the versions so we can assess the impact of this and merge with the other card if necessary?

Jdlrobson added subscribers: Nirzar, pizzzacat.

As discussed @Nirzar can you talk to @pizzzacat about this and turn this into a real bug.

Jhernandez moved this task from Triaged but Future to Needs Analysis on the Readers-Web-Backlog board.
Jhernandez added a subscriber: Jhernandez.

@Jdlrobson to test this out (from kickoff/standup meeting)

Jdlrobson closed this task as Resolved.Jul 5 2016, 5:05 PM

There is no issue with Hovercards in Chrome on Windows at time of writing:


The issue @pizzzacat discusses is T68496 and unrelated and has been fixed.