Page MenuHomePhabricator

[betalabs] Uncaught TypeError: Cannot read property 'commandRegistry' of null
Closed, ResolvedPublic

Description

  1. In betalabs, click on Reply on any Flow page post.
  2. Switch to VE - type something and click on link or mention icons. The link/mention inspectors flashed for a sec and disappeared.
  3. Click on 'Reply' button - the following error is displayed:
Uncaught TypeError: Cannot read property 'commandRegistry' of null
 ve.ui.Tool.getCommand @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:458
ve.ui.Tool.onUpdateState @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:458mw.loader.implement.oo.EventEmitter.emit @ VM2158:169
ve.ui.Toolbar.updateToolState @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:462
ve.ui.Toolbar.onContextChange @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:460mw.loader.implement.oo.EventEmitter.emit @ VM2158:169
ve.dm.Surface.stopQueueingContextChanges @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:130
ve.dm.Surface.changeInternal @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:134
ve.dm.Surface.change @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:133
ve.ce.Surface.changeModel @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:393
ve.ce.Surface.onSurfaceObserverRangeChange @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:367mw.loader.implement.oo.EventEmitter.emit @ VM2158:169
ve.ce.SurfaceObserver.pollOnceInternal @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:396
ve.ce.SurfaceObserver.pollOnce @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:395
ve.ce.Surface.onDocumentBlur @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:337
ve.ce.Surface.onFocusChange @ load.php?debug=false&lang=en&modules=ext.visualEditor.core%2Cmediawiki%2Cmwcore%2Cmwlink%2Cmwtransc…:335OO.ui.debounce.later

Event Timeline

Etonkovidova updated the task description. (Show Details)
Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 12 2015, 9:34 PM
Catrope added a subscriber: Catrope.

This might be fixed with the new editor work that was merged like 5 minutes ago?

Catrope triaged this task as High priority.Aug 12 2015, 11:13 PM
Etonkovidova updated the task description. (Show Details)Aug 13 2015, 5:57 PM
Etonkovidova set Security to None.

Re-checked in betalabs after "Add an editor widget https://gerrit.wikimedia.org/r/220665" - the issue is fixed.

Etonkovidova closed this task as Resolved.Aug 17 2015, 7:15 PM