Unable to link to titles containing double- or triple-apostrophes
Closed, ResolvedPublic

Description

Author: ais523

Description:
(I don't think that this is a duplicate of bug 8367) It's possible to upload an image
with a name like "Image:Test''Apostrophe.PNG", which contains two consecutive
apostrophes. However, such an image is unusable because the parser treats the apostrophes
like wikimarkup and doesn't include the image. (This actually came up in a helpme request
on enwiki, so it isn't entirely theoretical, although I agree that using '' in the name
of an image is just confusing.)


Version: 1.10.x
Severity: normal
URL: http://test.wikipedia.org/wiki/User:Ais523/TestApostrophe

Details

Reference
bz8932
bzimport set Reference to bz8932.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Feb 9 2007, 6:45 PM

You can replace the apostrophes with html entities and it should work.

Reopening. There's likely a duplicate bug somewhere, though I can't find an earlier one at this moment. Comment 1 suggests a workaround, but this bug is not resolved.

Apostrophes shouldn't cause breakage in valid syntax.

tgkprog wrote:

it is difficult to post a link to article with even one apostrophe if you can get the text out of http://en.wikipedia.org/w/index.php?title=Apostrophe_wiki_urls&action=edit&redlink=1 then will see a sample - big problem posting it in some sites like http://www.plime.com/ can we have a work around/ mirror address without the apostrophes so current links are valid and we have a alternate? or is the best answer to use a redirect - tiny url site?

  • Bug 25229 has been marked as a duplicate of this bug. ***
  • Bug 25532 has been marked as a duplicate of this bug. ***

Looks fixed with r68491 - the test case under the url works for me

Add Comment