Page MenuHomePhabricator

[betalabs] 'Cancel' Summarize gives "Cannot read property 'commandRegistry'"
Closed, ResolvedPublic

Description

The same error message as in T108876

  1. Open 'Summarize' for a topic
  2. Open 'Reply' for the same topic.
  3. Click 'Cancel' for 'Reply'
  4. Click 'Cancel' for 'Summarize'
  5. Again open 'Summarize' for a topic - - Console displays the error.

If steps #3 and #4 if are done in reverse order - there is no error.

Uncaught TypeError: Cannot read property 'commandRegistry' of null
ve.ui.Tool.getCommand @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:456
ve.ui.Tool.onUpdateState @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:455mw.loader.implement.oo.EventEmitter.emit @ VM6518:169
ve.ui.Toolbar.updateToolState @ 
load.php?debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:459
ve.ui.Toolbar.onContextChange @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:458mw.loader.implement.oo.EventEmitter.emit @ 
VM6518:169ve.dm.Surface.stopQueueingContextChanges @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:130
ve.dm.Surface.changeInternal @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:134ve.dm.Surface.change @ load.php?debug=false&lang=en&modules=ext.visualEditor.core|oojs-
ui.styles.icons-editing-advanced&sk…:133
ve.ce.Surface.changeModel @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:394ve.ce.Surface.onSurfaceObserverRangeChange @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:368mw.loader.implement.oo.EventEmitter.emit @ 
VM6518:169
ve.ce.SurfaceObserver.pollOnceInternal @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:397
ve.ce.SurfaceObserver.pollOnce @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:396
ve.ce.Surface.onDocumentBlur @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:337
ve.ce.Surface.onFocusChange @ load.php?
debug=false&lang=en&modules=ext.visualEditor.core|oojs-ui.styles.icons-editing-
advanced&sk…:335OO.ui.debounce.later

Event Timeline

Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova updated the task description. (Show Details)
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 20 2015, 7:04 PM
Etonkovidova updated the task description. (Show Details)Aug 20 2015, 7:06 PM
Etonkovidova set Security to None.
Etonkovidova updated the task description. (Show Details)Aug 25 2015, 7:33 PM
Catrope triaged this task as Normal priority.Aug 26 2015, 11:57 PM
Catrope added a subscriber: Catrope.

@Etonkovidova: could you verify if this is still happening? I cannot reproduce it.

Etonkovidova closed this task as Resolved.Sep 29 2015, 4:24 PM
Etonkovidova updated the task description. (Show Details)

Re-checked in betalabs(1.27alpha (18601dd))- was fixed by T109000: Use EditorWidget for edit post