Page MenuHomePhabricator

Upgrade Camus
Closed, ResolvedPublic

Description

The version of Camus that we run has a bug where it will not properly consume from partitions that have a replica down. This is dumb! The whole point of Kafka is that it is resilient to individual broker failures.

Newer versions of Camus have fixed this bug, so we should upgrade.

Event Timeline

Ottomata created this task.Aug 21 2015, 5:18 PM
Ottomata claimed this task.
Ottomata raised the priority of this task from to Normal.
Ottomata updated the task description. (Show Details)
Ottomata added a project: Analytics-Cluster.
Ottomata added a subscriber: Ottomata.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 21 2015, 5:18 PM

Change 233044 had a related patch set uploaded (by Ottomata):
Upgrade camus to version wmf6

https://gerrit.wikimedia.org/r/233044

Change 233044 merged by Joal:
Upgrade camus to version wmf6

https://gerrit.wikimedia.org/r/233044

ggellerman set Security to None.
ggellerman moved this task from Next Up to In Code Review on the Analytics-Kanban board.
ggellerman moved this task from In Code Review to Done on the Analytics-Kanban board.
kevinator closed this task as Resolved.Aug 25 2015, 11:29 PM
kevinator added a subscriber: kevinator.