Page MenuHomePhabricator

Make it clearer that you can use a free-form date in UploadWizard by clicking the button next to the date input
Closed, ResolvedPublic

Description

I understand the requirement for the Special uploader to require a date field to be completed to progress, however, the recent imposition of the sole requirement for an exact date to the day is an overreaction, and simply wrong. For works that were published years ago, and are now out of copyright, there is generally only the ability to specify a year, and for some photographs published in books or from archives there may only be the capacity to presume a decade. So now we are forcing an exact and not necessarily accurate date.

Possible solutions

  • rollback and not force a specific date
  • have radio buttons that allow for alternates to exact dates, eg. year only, that takes YYYY; and a circa dropdown that allows one of the existing categories, eg. year, decade, century. Flag those if you really wish to monitor

Either way, forcing people to put in incorrect data is not a solution that should be chased.

Event Timeline

Billinghurst raised the priority of this task from to Needs Triage.
Billinghurst updated the task description. (Show Details)
Billinghurst added a subscriber: Billinghurst.
Restricted Application added a project: Multimedia. · View Herald TranscriptAug 24 2015, 11:46 AM
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald Transcript
Billinghurst set Security to None.
Restricted Application added a subscriber: Matanya. · View Herald TranscriptAug 24 2015, 11:47 AM
Jdforrester-WMF renamed this task from Commons special upload requires a date but will not take a year alone to Make it clearer that you can use a free-form date in UploadWizard by clicking the button next to the date input.Aug 24 2015, 2:56 PM
Jdforrester-WMF triaged this task as Normal priority.

You can click the cog icon next to the field to switch to a freeform text field.

Clearly this is not obvious enough :) We could try changing it to a different icon, or just make it textual. I fear that we'll end up with something where the switcher is more prominent than the date field.

Why not detect if somebody begins a date with {{? This was a really confusing situation the first time I've experienced it.

Maybe just using "tipsy" for the tooltip (like for the [?] icons, also visible in the screenshot), which is immediate, instead of browser native tooltips (which have a delay), would help?

Ideas welcome. I'll be happy to implement a solution as soon as we come up with something sensible.

Hmm I did click an icon, not that it was intuitive (or resolved my issue).

Not in front of the uploader and don't have something to upload, but will
see what I can do to reproduce, and review.

Even the help text/refusal message could be guiding. Rather than a flat
"need date!" it could say "full date OR configure date field by... "

Change 233772 had a related patch set uploaded (by Bartosz Dziewoński):
Redesign switcher between calendar and freeform date inputs

https://gerrit.wikimedia.org/r/233772

How about this:

Instead of a single icon to the right we have two icon buttons, with icons (hopefully better ones) and tooltips. Thoughts?

Why not detect if somebody begins a date with {{?

Hmm, interesting, this could work well for power-users.

We can also make the option "No specific month/day" an option on the date picker.

That works for me AND it has portability for the whole system, which has
advantages.

Steinsplitter moved this task from Incoming to Uploading on the Commons board.Aug 26 2015, 2:05 PM

@Billinghurst which solution did you mean works for you?

Billinghurst added a comment.EditedAug 26 2015, 8:59 PM

Was talking to Matma's contribution. Was via email so apologies if not in context.

Jdforrester-WMF moved this task from Untriaged to Doing on the Multimedia board.Aug 27 2015, 3:49 PM
Jdforrester-WMF moved this task from Doing to Needs code review on the Multimedia board.
RP88 added a subscriber: RP88.Aug 28 2015, 2:41 AM

Change 235052 had a related patch set uploaded (by Bartosz Dziewoński):
Help users trying to input a template as upload date

https://gerrit.wikimedia.org/r/235052

Change 233772 merged by jenkins-bot:
Redesign switcher between calendar and freeform date inputs

https://gerrit.wikimedia.org/r/233772

MarkTraceur closed this task as Resolved.Aug 31 2015, 7:15 PM
MarkTraceur claimed this task.

Merged redesign, marking as resolved, this should go out to testwikis tomorrow, and Commons on Wednesday.

Change 235052 merged by jenkins-bot:
Help users trying to input a template as upload date

https://gerrit.wikimedia.org/r/235052