Page MenuHomePhabricator

Editing posts: Keep input focus when switching from VE to wikitext editing
Closed, ResolvedPublic

Description

Split from T97290

In Chrome and FF.

  1. Start editing a post on Flow board.
  1. Click to switch to a different editor
    • switching from VE->wikitext: focus is lost.
    • switching from wikitext ->VE: the cursor is placed at the beginning of present text

Event Timeline

Etonkovidova updated the task description. (Show Details)
Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 24 2015, 6:51 PM
Catrope added a subscriber: Catrope.

Editing existing posts still uses the old editor system; this bug should be fixed once we migrate that to the new editor system.

DannyH triaged this task as Normal priority.Aug 24 2015, 8:38 PM
DannyH set Security to None.
DannyH moved this task from Untriaged to Near-Term Interest on the Collaboration-Team-Triage board.

Edit post now uses the new editor and that should be fixed.

Checked in betalabs.

  • When switching between editing modes the behavior of cursor placement is consistent - this is an improvement.
  • Current behavior: If your cursor is placed for editing at the beginning or in the middle of a big chunk of text - switching to another editing mode will always place a cursor at the end of the text.
DannyH closed this task as Resolved.Sep 25 2015, 8:43 PM
DannyH claimed this task.
DannyH added a subscriber: DannyH.

The behavior Elena noted (switching moves the cursor to the end) is acceptable.