Page MenuHomePhabricator

archivebot does not archive MediaWiki message delivery
Closed, DeclinedPublic

Description

MediaWiki message delivery have not correct (localised) timestamp at the end and they are not archived in namespace 4
https://cs.wikipedia.org/w/index.php?title=Wikipedie:Pod_l%C3%ADpou&curid=327994&diff=12836434&oldid=12814697

but in namespace 2 they are archived
https://cs.wikipedia.org/w/index.php?title=Diskuse_s_wikipedistou:JAn_Dud%C3%ADk&diff=prev&oldid=12836427

Event Timeline

JAnD created this task.Aug 24 2015, 8:15 PM
JAnD raised the priority of this task from to Medium.
JAnD updated the task description. (Show Details)
JAnD added a project: Pywikibot-archivebot.py.
JAnD added a subscriber: JAnD.
Restricted Application added subscribers: pywikibot-bugs-list, Aklapper. · View Herald TranscriptAug 24 2015, 8:15 PM
whym added a subscriber: whym.Jan 30 2016, 7:19 AM

As mentioned, archivebot.py as of now requires a well-formed localized timestamp. Would it be a good idea to modify it recognize English timestamps and localized timestamps on a non-English wiki?

I'm guessing that providing it as an option for the operator would be uncontroversial.

Mpaa added a subscriber: Mpaa.EditedJan 30 2016, 9:33 AM

The problem is what is a well-formed English timestamp.
In the MediaWiki message delivery example above the format is "9 September 2014 16.22 (UTC)" while on enwp, for example, the format is "06:56, 30 January 2016 (UTC)".

The idea in archivebot is to understand the format of the date from the siteinfo informations.

whym added a comment.EditedFeb 5 2016, 9:58 AM

@Mpaa: Good point. In light of that, I'd suggest closing this as not done. It appears the problem was in the text, not in the bot.

However, to expand on my last comment, it might make sense to allow the operator to provide a format string as a fallback (e.g. '-fallback_format:"%d %B %Y %H.%M (UTC)"'). That may be a different phabricator task to create, though.

whym closed this task as Declined.Nov 28 2016, 11:38 AM