Page MenuHomePhabricator

Banners should be visible in the printable version of the page
Closed, ResolvedPublic

Description

Given you have WIkidataPageBanner installed (http://mediawiki.org/wiki/Extension:WikidataPageBanner) and are viewing a page with a banner e.g. http://en.wikivoyage.beta.wmflabs.org/wiki/WikidataPageBanner_example_2

Currently banners are not shown in the print view when the reader clicks the browser print (Ctrl + P) function in a modern browser.

The heading should be visible in the printable version
The banner image should not (although that may change in future).

Event Timeline

Jdlrobson raised the priority of this task from to Needs Triage.
Jdlrobson updated the task description. (Show Details)
Jdlrobson moved this task to Epics on the Wikidata-Page-Banner board.
Jdlrobson added a subscriber: Jdlrobson.
Restricted Application added a project: Wikidata. · View Herald TranscriptAug 25 2015, 4:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

I'm fine with the banners not printing, as they're largely decorative and would be a waste of paper, we do need to at least print the article title and some sort of table of contents.

Oh I hadn't thought about the heading but yes we should definitely show that.
What is the reasoning behind printing the table of contents (curious)?

It just seems like something useful, following the precedent of printed books. But perhaps our articles are better analogized as chapters rather than as entire books, obviating the need for TOCs unless printing several articles.

I think that it would be useful for banners to print because:

  1. The page title is not displayed particularly clearly, making it hard to find the right printout in a pile.
  2. Printouts should generally match what is seen online, as this is what most readers expect.
  3. For many smaller pages the banner is either the only picture, or is the only one showing a particular type of image.
  4. Banners are a distinctive feature of Wikivoyage. It would be helpful to have them on printouts passed around or put up on notice boards. This would help to "advertise" Wikivoyage.

I can see that we migh have wanted banners not to print when they were first introduced, as most pages would have the default grey banner, which would not be a good use of ink. Now a third of articles have custom banners, and I think most printouts will be of articles with custom banners.

If there are difficulties printing as a banner sized to fit the page, it could be printed at a fixed size (e.g 525 x 75 or 350 x 50)

Jdlrobson updated the task description. (Show Details)Aug 25 2015, 10:39 PM
Jdlrobson set Security to None.
Jdlrobson moved this task from Epics to Backlog on the Wikidata-Page-Banner board.Aug 28 2015, 7:28 PM
Jdlrobson renamed this task from Should banners be visible in the printable version of the page to Banners should be visible in the printable version of the page.Sep 16 2015, 12:35 AM
Jdlrobson added a project: good first bug.
Jdlrobson moved this task from Backlog to Epics on the Wikidata-Page-Banner board.
Sumit moved this task from In discussion to In discussion on the Wikidata-Page-Banner board.
Jdlrobson triaged this task as High priority.Sep 23 2015, 6:05 PM

I think at very least we have to make the headings show up in the noprint version and I'd say doing this is a high priority.

I will mentor this in #GCI2015

Jdlrobson will mentor this task, as mentors must be community members already.

@Jdlrobson: For a potential GCI contributor, could you clarify which codebase this task is about and how to reproduce the problem? Is this MediaWiki core's "Printable version" functionality in the side bar? Is this code in the mediawiki/extensions/WikidataPageBanner Git repository only? Or both?

Jdlrobson lowered the priority of this task from High to Normal.Dec 9 2015, 6:51 PM
Jdlrobson updated the task description. (Show Details)Dec 9 2015, 6:53 PM
Jdlrobson updated the task description. (Show Details)

Change 260406 had a related patch set uploaded (by Scimonster):
Don't show WikidataPageBanner when printing

https://gerrit.wikimedia.org/r/260406

Change 260406 merged by jenkins-bot:
Don't show WikidataPageBanner when printing

https://gerrit.wikimedia.org/r/260406

Jdlrobson closed this task as Resolved.Dec 23 2015, 9:31 PM