Writing any posts through the mobile Flow interface is completely impossible
Closed, ResolvedPublic

Description

Today I noticed that it's completely impossible to write any Flow posts through the mobile interface.

To reproduce, simply try typing a reply to any topic at https://m.mediawiki.org/wiki/Talk:CX (notice the m in the beginning). Start a new topic is broken, too: you can type the subject, but not the opening post. Nothing can be typed at all.

I tried it with Samsung Galaxy S5 with Firefox and Chrome, and with desktop Firefox on the mobile site (m).

On the non-mobile site it works correctly.

Amire80 created this task.Aug 27 2015, 5:48 AM
Amire80 updated the task description. (Show Details)
Amire80 raised the priority of this task from to Unbreak Now!.
Amire80 added subscribers: phuedx, EBernhardson, Quiddity and 6 others.

Seems to be a regression in the new editor system. The <textarea> for submitting a post remains pending and disabled. There's also no toolbar. Probably a module loading problem.

Amire80 renamed this task from Writing any posts through the mobile interface is completely impossible to Writing any posts through the mobile Flow interface is completely impossible.Aug 27 2015, 6:51 AM

Change 234219 had a related patch set uploaded (by Catrope):
Fall back to the first available editor when the preferred editor is not available

https://gerrit.wikimedia.org/r/234219

Change 234219 merged by jenkins-bot:
Fall back to the first available editor when the preferred editor is not available

https://gerrit.wikimedia.org/r/234219

I would highly recommend writing some lightweight browser tests for Flow mobile. Happy to help if needed.

Start a new topic is broken, too: you can type the subject, but not the opening post. Nothing can be typed at all.

Checked it in betalabs http://en.m.wikipedia.beta.wmflabs.org/wiki/

  • on desktop
  • on Ipod mini

Currently editing is possible only with wikitext.

DannyH closed this task as Resolved.Aug 28 2015, 5:36 PM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJul 11 2016, 10:33 PM