Page MenuHomePhabricator

reformulate kafkatee package to work with Trusty
Closed, ResolvedPublic

Description

Our kafkatee depends on systemd and thus doesn't play well with Trusty. There might be other dependency issues too, as it's built from more recent local versions of dependency packages than stock trusty. The task is to create upstart or traditional init config, and to make sure none of the dependency mismatches are significant.

Event Timeline

Jgreen created this task.Aug 27 2015, 8:32 PM
Jgreen claimed this task.
Jgreen raised the priority of this task from to Medium.
Jgreen updated the task description. (Show Details)
Jgreen added a project: acl*sre-team.
Jgreen added a subscriber: Jgreen.
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptAug 27 2015, 8:32 PM
Jgreen added a parent task: Restricted Task.Aug 27 2015, 8:33 PM
Jgreen added a parent task: Restricted Task.Aug 28 2015, 9:06 PM
faidon added a subscriber: faidon.Aug 28 2015, 9:07 PM

Can't we just start upgrading fundraising systems to jessie?

Can't we just start upgrading fundraising systems to jessie?

No I don't think that's feasible this year.

Jgreen set Security to None.
Jgreen added a subscriber: Ottomata.
Jgreen raised the priority of this task from Medium to High.Sep 14 2015, 1:34 PM

Minor bug--in kafkatee.upstart first line:

-description "kafkatee
+description "kafkatee"

working fine

Jgreen closed this task as Resolved.Sep 16 2015, 4:26 PM