Page MenuHomePhabricator

Flow breaks links to subpage, when part before / finishes with full stop
Closed, ResolvedPublic

Description

Flow breaks links to userspace (or maybe it's VisualEditor? or maybe the Linker in core?).

Reuven M., a user in the Hebrew Wikipedia volunteered to test Flow on his user page. His user name ends with a full stop. He created a subpage in his user space and tried to link to it from a Flow post. The title of the page is "שיחת משתמש:ראובן מ./פרהיסטוריה". For reference:

  • "שיחת משתמש" is "User talk".
  • "ראובן מ." is the user name.
  • "פרהיסטוריה" is the name of the subpage.

He tried to link to it, but the link appeared as red, and clicking it leads to "שיחת משתמש:ראובן מפרהיסטוריה", that is, the "./" from the middle of the subpage's whole title disappeared.

To make it easier for people who don't know Hebrew, I tried to reproduce it in mediawiki.org with "User talk:Full Stop Aharoni./subpage", but it seems to work correctly in mediawiki.org with Latin characters, so it's quite odd.

It's one the verge of "Unbreak now", but I'll restrain myself :)


  1. Not just Hebrew, any Wiki.
  2. Not just user talk, any namespace
  3. More than one "." disappear exactly two.
  4. It does work in preview, on post creation or editing.

Event Timeline

Amire80 created this task.Aug 28 2015, 1:52 PM
Amire80 raised the priority of this task from to High.
Amire80 updated the task description. (Show Details)
Amire80 added a project: StructuredDiscussions.
Amire80 added subscribers: Amire80, Mooeypoo, DannyH.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 28 2015, 1:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

For what it's worth, it does work when editing a non-Flow page in VisualEditor. See https://he.wikipedia.org/wiki/%D7%9E%D7%A9%D7%AA%D7%9E%D7%A9:Amire80/T110676 .

But on Flow it breaks: https://he.wikipedia.org/wiki/%D7%A0%D7%95%D7%A9%D7%90:Snurbzjim8rddkau

IKhitron set Security to None.Aug 28 2015, 2:03 PM
IKhitron added a subscriber: IKhitron.
Mattflaschen-WMF renamed this task from Flow breaks links to userspace in the Hebrew Wikipedia to Flow breaks links to user talk subpage, when part before / contains full stop, in the Hebrew Wikipedia.Aug 28 2015, 4:21 PM

This also happens in English, as well. A link to "Somepage./Subpage" leads to "SomepageSubpage".

IKhitron renamed this task from Flow breaks links to user talk subpage, when part before / contains full stop, in the Hebrew Wikipedia to Flow breaks links to subpage, when part before / finishes with full stop.Aug 28 2015, 4:44 PM

Indeed, it's not just in English, see here. And it's in any namespace, not just user talk, see the same example.

More than that: if the name includes more than 1 "." before "/", exactly TWO "." disappear.

IKhitron updated the task description. (Show Details)Aug 28 2015, 4:49 PM
IKhitron updated the task description. (Show Details)
IKhitron updated the task description. (Show Details)

But if you open the post for editing you can see in preview/VE the right link. Exit will destroy it again.

@IKhitron yes, the problem is found, we're fixing now. Thank you for helping narrow this down!

Mooeypoo assigned this task to Catrope.Aug 28 2015, 4:59 PM

Change 234571 had a related patch set uploaded (by Catrope):
Anchor the regex for ./ stripping

https://gerrit.wikimedia.org/r/234571

Change 234571 merged by jenkins-bot:
Anchor the regex for ./ stripping

https://gerrit.wikimedia.org/r/234571

Change 234574 had a related patch set uploaded (by Catrope):
Anchor the regex for ./ stripping

https://gerrit.wikimedia.org/r/234574

Change 234574 merged by jenkins-bot:
Anchor the regex for ./ stripping

https://gerrit.wikimedia.org/r/234574

Fix is live now, and confirmed working. Thanks for reporting this. Sorry it took 3 hours; most of us were asleep when this bug was reported.

Catrope closed this task as Resolved.Aug 28 2015, 5:12 PM

Indeed working.
Thanks a lot!