Page MenuHomePhabricator

Wikidata blame
Closed, DeclinedPublic

Description

I want to know who added "Chichi" at https://www.wikidata.org/wiki/Q2105

I haven't found any better way than diffing by dichotomy, which is very laborious.

There should be a better way to find who wrote what, a tool a bit like git blame or wikiblame.

Event Timeline

Nicolas_Raoul raised the priority of this task from to Normal.
Nicolas_Raoul updated the task description. (Show Details)
Nicolas_Raoul added a project: Wikidata.
Nicolas_Raoul added a subscriber: Nicolas_Raoul.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2015, 1:05 PM

Thanks Bugreporter, nice to see that there is some source code available already!

Hopefully the feature can be included natively into the Wikidata web UI soon :-)

Nicolas_Raoul reopened this task as Open.Feb 15 2018, 4:39 PM
Lydia_Pintscher closed this task as Declined.Feb 15 2018, 5:07 PM
Lydia_Pintscher added a subscriber: Lydia_Pintscher.

It is still a duplicate of the other one. Please leave this one closed.

Me: It would be very convenient if we had a tool to cut paper.
A: We could use a thermonuclear quantum laser for that. Closing as duplicate.
B: Sorry guys, we cannot have a thermonuclear quantum laser.
Me: Wait, closing as duplicate was a mistake in the first place, I don't need a thermonuclear quantum laser... How about plain old scissors?

We don't need "statement edit metadata" to implement this basic feature that any wiki has.

It could even be implemented 100% client-side, in JavaScript. Such an implementation would require zero server-side code change, and its usage would generate no more load than a few pageviews. It would use the existing "action=history" and "type=revision" API calls, which are very light.

Please reopen, thanks :-)