Page MenuHomePhabricator

User menu problem in blueprint skin
Closed, InvalidPublic

Description

Hi when using the blueprint skin I am getting the user menu problem the menu doesent show correctly and dosent show at all and looks out of place

to reproduce

  1. download blueprint skin.
  1. follow install steps to install skin.
  1. go to your website with blueprint skin installed then try clicking on the user menu which should be on the right. It wont show.

It should show menu when clicked.

Event Timeline

Paladox created this task.Aug 30 2015, 5:31 PM
Paladox raised the priority of this task from to Needs Triage.
Paladox updated the task description. (Show Details)
Paladox added a project: Blueprint.
Paladox added subscribers: Paladox, Volker_E.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2015, 5:31 PM

Change 230410 had a related patch set uploaded (by Paladox):
Improvements to Blueprint skin

https://gerrit.wikimedia.org/r/230410

@Paladox Does it look out of place or doesn't it show up at all?
Could you provide a screenshot?

Well it is out of place and doesn't show.

And I am currently not using the skin. I was to be able to test the patches I upload.

@Paladox So it's hidden outside the viewable area or not shown at all? Do you get JS errors in console?

No js error is shown but it doesn't show.

No js error is shown but it doesn't show.

@Paladox Which browser are you using?

Internet explorer, chrome, Microsoft edge.

@Paladox At which resolution do you run into the problem? I've seen, that you've also changed container width? Why's that?

Well not sure what resolution I think at 720p. And it's the problem that your having with a patch that removes the composer but uploaded by another user this fixed the problem since it has nothing to do with his or her patch it is to do with bootstrap files

Please find out your exact screen resolution. As debugging gets much harder on my side without having this information.

What problem do you think I have? What are you referring to? The container width change by you? Your last sentence is hard for me to understand.

I think it is running at 720p and yes container width the problem you described in spage patch is what I was seeing and found that the problem was container width.

Volker_E triaged this task as Lowest priority.Sep 14 2015, 5:46 AM
Volker_E set Security to None.

Change 230410 abandoned by Paladox:
Improvements to Blueprint skin

Reason:
Split some of these patches which can be found at

https://gerrit.wikimedia.org/r/#/c/239876/

and

https://gerrit.wikimedia.org/r/#/c/239878/

https://gerrit.wikimedia.org/r/230410

Change 239878 had a related patch set uploaded (by Paladox):
Fix user menu issue

https://gerrit.wikimedia.org/r/239878

With latest Blueprint master and a fairly recent 1.26 MediaWiki core, the account menu dropdown appears perfectly on click in Firefox and chromium for me, so long as the window is wide enough to not trigger Blueprint's horrible top bar layout problems (see T103730 and F183811). Here's what it looks like in Firefox when logged in as Admin user:

This is far from perfect (confusing repeat of username, no icons, the 0 for Notifications, etc.) But what exactly is wrong and different in your case? Screenshot or it didn't happen :-)

Hi yes this patches fixes that by making it the width of the button and is closed by default with us and will open when clicked using js.

@Paladox Which patch? Your patch? What @Spage said, the menu works in recent 1.26 MediaWiki core with current master (= without your patch)! We have a problem reproducing your error. Please provide a screenshot of your current problem with Blueprint master on your MediaWiki installation without applying your patch.

The image taken above that he says work is what I get and that's what the patch fixes it closes the menu by default you have to clicked it to open it now.

@Paladox Do I understand you correctly, that you are saying, the user menu is per default open in your installation?

Yes including in the image above.

But in the image above, this is the menu shown onclick.
If you access a page, (given MW 1.26 and Blueprint master), the menu isn't open per default on our machines?!

Oh it's open on mine. I haven't used it recently but a few wmf 1.26 releases back it was.

In the task description you say 'with blueprint skin installed then try clicking on the user menu which should be on the right. It wont show.'
So is it open per default OR doesn't it show up on click?

It is open by default whereas on one of your wikimedia wiki website not sure which one that is testing it has it as closed by default.

If you're installation loads the Bootstrap CSS file, it includes

.dropdown-menu {
    display: none;
}

So the user menu dropdown can't be shown. Can you assure that there's no misconfiguration in your installation and all CSS files get loaded?
A screenshot with the dropdown in the inspector would probably help.

From current perspective, I'm inclined to close this task as 'Invalid'.

Volker_E closed this task as Invalid.Nov 5 2015, 4:28 AM
Volker_E moved this task from Backlog to Done on the Blueprint board.Dec 21 2015, 4:07 PM

Change 239878 abandoned by Aklapper:
Fix user menu issue

Reason:
No reply to last comment, hence abandoning this patch.

https://gerrit.wikimedia.org/r/239878