Page MenuHomePhabricator

Post-Deployment discussion for Russian Wikivoyage
Closed, ResolvedPublic

Description

I tried to use the bottomtoc= parameter in {{PAGEBANNER}}, and it simply does not work. I get the standard TOC and nothing on the banner or below it (where the TOC should be). The current description at:

https://www.mediawiki.org/wiki/Extension:WikidataPageBanner

gives somewhat conflicting information on whether I should use bottomtoc=yes or write

.wpb-topbanner-toc{

position: relative;

}

in Mediawiki:Common.css. But none of those two give the result that I need. Any help will be appreciated!

Event Timeline

Atsirlin created this task.Sep 2 2015, 3:32 PM
Atsirlin raised the priority of this task from to Normal.
Atsirlin updated the task description. (Show Details)
Atsirlin added a project: Wikidata-Page-Banner.
Atsirlin added subscribers: Atsirlin, Jdlrobson, Sumit.
Restricted Application added a project: Wikidata. · View Herald TranscriptSep 2 2015, 3:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Sorry, I forgot to provide an example. It's here:

https://ru.wikivoyage.org/wiki/Пярну

Sumit added a comment.Sep 2 2015, 3:35 PM

@Atsirlin, you'll also need to set toc=yes as a parameter, to see toc and at bottom, refer to the above example, which I've corrected :)

Thanks, Sumit. It was not straight-forward!

Two more questions:

i) multi-line TOC has large spacing between the lines. Compare, for example,
https://ru.wikivoyage.org/wiki/Москва (new format)
https://ru.wikivoyage.org/wiki/Прага (old format)
Is it possible to reduce this line spacing, or, ideally, to have it adjustable?

ii) So far we had a bit of white space between the bottom of the banner and the top of the TOC (see same articles as above). We will discuss whether we prefer to remove this white space now, but this may be another parameter that is worth customizing.

Jdlrobson renamed this task from bottomtoc=yes parameter does not work to Post-Deployment discussion for Russian Wikivoyage.Sep 2 2015, 3:53 PM
Jdlrobson set Security to None.

@Atsirlin I see that Russian Wikivoyage is using maps but they do not work on mobile. Who do I speak to about that? How are they implemented?

Sumit added a comment.EditedSep 2 2015, 3:59 PM

i) multi-line TOC has large spacing between the lines. Compare, for example,
https://ru.wikivoyage.org/wiki/Москва (new format)
https://ru.wikivoyage.org/wiki/Прага (old format)
Is it possible to reduce this line spacing, or, ideally, to have it adjustable?

Yes it is possible to see the old view, just set:

.wpb-banner-toc{
    line-height: 1.0em;
}

in MediaWiki:Common.css

ii) So far we had a bit of white space between the bottom of the banner and the top of the TOC (see same articles as above). We will discuss whether we prefer to remove this white space now, but this may be another parameter that is worth customizing.

Set

.wpb-topbanner-toc{
    margin-top:5px;
}

in Mediawiki:Common.css
The entire toc is customizable from MedaiWiki:Common.css
I've included the above two examples in https://www.mediawiki.org/wiki/Extension:WikidataPageBanner#Styling for future reference

@Jdlrobson: You can talk to me. The maps are embedded using the same java script as on English Wikivoyage, but then these embedded maps are placed into a collapsible environment.

Map should be folded by default, but in the mobile version it is automatically unfolded. In fact, there are certain features of the map embedding that I do not understand, and I would be grateful if you could provide us technical assistance. Should we perhaps continue on-wiki because the maps are independent from pagebanners?

@Sumit: Thanks! I think that I understood the principle, although an extended manual would be, of course, very useful.

@Sumit: sorry, one more question. I implemented dots between section titles using the style from English Wikivoyage. It looks fine on most of the screens, but on the 12-inch screen the desktop version becomes weird. All dots go under the section titles. Same problem on English Wikivoyage, although nobody reported it so far. Do you know why it could happen, and how to fix this?

Sumit added a comment.Sep 2 2015, 7:38 PM

@Atsirlin, can you provide an example link so that I can create a task to resolve that?

Sumit added a comment.Sep 2 2015, 7:47 PM

@Atsirlin, on a side note, English Wikivoyage is using

.ext-wpb-pagebanner li.toclevel-1 > a:after {
    content: " ·";
    font-weight: bold;
    padding: 0 0 0 0.1em;
}

whereas MediaWiki:Common.css on Russian Wikivoyage shows:

.ext-wpb-pagebanner li.toclevel-1:after {
    content: " ·";
    font-weight: bold;
    padding: 0 0 0 0.1em;
}

Note the missing " > a:"

@Sumit, it looks like my problem was solved by this fix. Perhaps I copied the code from the old version of Mediawiki:Common.css? I don't know, but it was my very weird mistake combined with some caching issues, when my laptop and table displayed banners differently at the same time.

Many thanks for your prompt and very efficient support!

Lydia_Pintscher moved this task from incoming to monitoring on the Wikidata board.Sep 3 2015, 12:26 PM
Jdlrobson closed this task as Resolved.Sep 4 2015, 12:30 AM
Jdlrobson claimed this task.
Jdlrobson moved this task from In discussion to Epics on the Wikidata-Page-Banner board.

Let us know if you need any more support or you find any bugs/problems with the software! thanks @Atsirlin!

@Jdlrobson, @Sumit: sorry for bothering you, but we have got another problem with ToC. All dots between section names are now on a separate line under the ToC, example here:
https://ru.wikivoyage.org/wiki/Бронницы

I see the same problem on English Wikivoyage, and it seems to be reproducible in Firefox and Chrome and also for different users.

Atsirlin added a comment.EditedNov 4 2015, 10:23 PM

@Jdlrobson: do you think that the '>' symbol should be removed? In fact, it is the opposite. Initially I forgot to add it, and we had exactly the same problem with dots under the ToC when the '>' symbol was not there. Then Sumit pointed me to this mistake (see the discussion above), I added '>', and everything went to normal. Today the ToC was broken and I tried to remove '>', simply as a blind guess, but this had no effect, so I reverted the change.

It would be helpful if you could explain me what this whole thing means. For example, we also have

.ext-wpb-pagebanner li.toclevel-1:last-child > a:after

in the same css file, but I have no idea how to read this, and whether '>' is needed. At the moment, we are using the same configuration as on English Wikivoyage, and they seem to experience the same problem

I'm not sure what's triggered the issue (maybe an HTML change in the fix for T92481 ) but given the css is in MediaWiki:Common.css it seems the issue should be fixed there. I suspect you'll want to apply the rule to the li tag rather than the a tag.

Bug resolved by adding

.toctext {display: inline;}

to Mediawiki:Common.css. Thanks to Andyrom75!

Fomafix added a subscriber: Fomafix.Nov 5 2015, 5:10 AM

Bug resolved by adding

.toctext {display: inline;}

to Mediawiki:Common.css. Thanks to Andyrom75!

The local definition must have a higher specificity because the order of loading is a race condition:

.wpb-banner-toc .toctext { display: inline; }

@Fomafix: I have changed this. Thank you!