Page MenuHomePhabricator

Upload nodepool_0.1.1-wmf2 package to apt.wikimedia.org to `jessie-wikimedia/thirdparty`
Closed, ResolvedPublic

Description

I have bumped the nodepool package from 0.1.0 to 0.1.1 (T107266) and to support statsd 3.x (T107268).

I have uploaded the resulting package on terbium and the result is available with either:

terbium.eqiad.wmnet:/home/hashar/public_html/debs/nodepool_0.1.1-wmf2/
https://people.wikimedia.org/~hashar/debs/nodepool_0.1.1-wmf2/

Can it be uploaded on apt.wikimedia.org to jessie-wikimedia/thirdparty please? Thank you.

Event Timeline

hashar raised the priority of this task from to Needs Triage.
hashar updated the task description. (Show Details)
hashar added subscribers: Aklapper, Matanya, hashar.
hashar renamed this task from Upload nodepool_0.1.1-wmf1 package to apt.wikimedia.org to `jessie-wikimedia/thirdparty` to Upload nodepool_0.1.1-wmf2 package to apt.wikimedia.org to `jessie-wikimedia/thirdparty`.Sep 3 2015, 10:14 AM
hashar updated the task description. (Show Details)
hashar set Security to None.

Bumped the package from wmf1 to wmf2 which includes python-statsd 3.x support (T107268).

hashar triaged this task as High priority.Sep 3 2015, 10:27 AM

Setting priority to high because that is preventing us from upgrading Nodepool and actually start it on labnodepool1001.eqiad.wmnet

Andrew closed this task as Resolved.Sep 3 2015, 2:37 PM
Andrew claimed this task.
Andrew added a subscriber: Andrew.

ok, should be all set. Let me know if it misbehaves.

The service started, awesome. Spurts some error but that is a configuration setting

2015-09-03 14:56:10,177 ERROR nodepool.NodePool: Could not update image ci-jessie-wikimedia on wmflabs-eqiad
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/nodepool/nodepool.py", line 1968, in updateImage
    self._updateImage(session, provider_name, image_name)
  File "/usr/lib/python2.7/dist-packages/nodepool/nodepool.py", line 1984, in _updateImage
    "Invalid image config. Must specify either "
Exception: Invalid image config. Must specify either a setup script, or a diskimage to use.

Thank you!