Page MenuHomePhabricator

UploadWizard enforces exact date, doesn't accept other forms
Closed, ResolvedPublic

Description

For the "date" field, UploadWizard enforces to select an exact date from the calendar, doesn't accept dating by month or by year only and doesn't use of {{other date}} template or its equivalent. Such a setting causes that uploaders insert many false entries if they don't know exact date of creation of the work.

Event Timeline

SJu created this task.Sep 2 2015, 8:28 PM
SJu raised the priority of this task from to Needs Triage.
SJu updated the task description. (Show Details)
SJu added a project: UploadWizard.
SJu added a subscriber: SJu.
Restricted Application added a project: Multimedia. · View Herald TranscriptSep 2 2015, 8:28 PM
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald Transcript

There should be a switcher next to the date field, allowing you to input any text in it. Furthermore, if you start typing '{{' into the field, it will automatically switch to the "any text" input mode. If you don't see it, can you provide a screenshot? If you do see it now, can you provide any suggestions to make it more obvious?

Restricted Application added a subscriber: Matanya. · View Herald TranscriptSep 2 2015, 8:36 PM
SJu added a comment.Sep 2 2015, 9:22 PM

I'm a bit confused. Now the form works as you say.

However, before ca. half an hour, I didn's see the switch and when I tried to copy the complete "other date" template to the field, the field get red and the form refused to accept the entry. Either i had a hallucination, or...

Tgr added a subscriber: Tgr.Sep 2 2015, 9:30 PM

Or you have the UW page open in a tab all the time and don't refresh it for days? Some people seem to do that. I wonder if some kind of auto-update feature made sense.

matmarex added a comment.EditedSep 2 2015, 9:40 PM

This was changed very recently, see T110026, because although the switcher was always there in the new design, it was hard to notice. It used to look like this:

In fact it seems like the change was deployed less than two hours ago, so you very well might have had an older tab open. I'm glad it works now; I think we can close this task? Thanks you for diligently reporting the isue :)

SJu added a comment.Sep 2 2015, 9:51 PM

I have surely not the UW page open for a time, I use it very rarely (I prefer Special:Upload for my own photos).

Let's suppose that I had an eclipse, I overlooked the switch and maybe the template was copied with initial space character?...

SJu added a comment.Sep 2 2015, 10:01 PM

I think, the task can be closed as mistaken or solved.

For possible investigation: the file i had problem with was https://commons.wikimedia.org/w/index.php?title=File:Star%C3%A1_Balabenka.jpg&oldid=170494417

matmarex closed this task as Resolved.Sep 2 2015, 10:34 PM

Thanks.