Page MenuHomePhabricator

ResourceLoaderFileModule::detectMissingImports: Tried to import missing file in mobile.special.nearby.styles: @import "../icons.less";
Closed, ResolvedPublic

Description

Error discovered with https://gerrit.wikimedia.org/r/#/c/235902/ + https://gerrit.wikimedia.org/r/#/c/235903/:

ResourceLoaderFileModule::detectMissingImports: Tried to import missing file in mobile.special.nearby.styles: @import "../icons.less";

https://integration.wikimedia.org/ci/job/mediawiki-extensions-hhvm/29725/consoleFull

Event Timeline

matmarex created this task.Sep 4 2015, 1:04 PM
matmarex updated the task description. (Show Details)
matmarex raised the priority of this task from to High.
matmarex added a project: MobileFrontend.
matmarex added a subscriber: matmarex.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 4 2015, 1:04 PM

This appears to be caused by 924126e7b929b9a1f62ab3a711f89a381d0c110f. I'm not sure if the line should be just removed (it does nothing now) or updated to point somewhere else. I'd appreciate if you fixed it soon, as it's blocking the merge of the linked patches.

Florian claimed this task.Sep 4 2015, 4:08 PM

I'll take a look in the next hours, if someone else doesn't have anything to do, feel free to take and fix this before me :P

Change 236054 had a related patch set uploaded (by Florianschmidtwelzow):
Remove import reference to missing file

https://gerrit.wikimedia.org/r/236054

Change 236054 merged by jenkins-bot:
Remove import reference to missing file

https://gerrit.wikimedia.org/r/236054

matmarex closed this task as Resolved.Sep 8 2015, 12:49 AM

Thanks.