Page MenuHomePhabricator

extensions/Flow - file permissions trigger debian lintian warnings
Closed, ResolvedPublic

Description

0) Context

DEB packages of mediawiki and many of its extensions, are prepared as part of the WP-MIRROR project.
See https://www.mediawiki.org/wiki/Wp-mirror.

  1. Lintian

During the build process, lintian performs a great number of sanity checks, including seeing if each file has file permissions appropriate to its file type.

When lintian sees a non-executable file with 755 permissions, rather than 644, lintian will throw a warning like:

W: wp-mirror-mediawiki: executable-not-elf-or-script usr/share/wp-mirror-mediawiki/extensions/Flow/includes/Data/BagOStuff/BufferedBagOStuff.php

  1. Files which should have permissions set to 644

extensions/Flow/includes/Data/BagOStuff/BufferedBagOStuff.php
extensions/Flow/includes/Data/BagOStuff/LocalBufferedBagOStuff.php

  1. Technical details

DEB standards version: 3.9.6
GIT branch: master

Details

Related Gerrit Patches:
mediawiki/extensions/Flow : masterchmod 644 for php files

Event Timeline

wpmirrordev assigned this task to Mattflaschen-WMF.
wpmirrordev raised the priority of this task from to Normal.
wpmirrordev updated the task description. (Show Details)
wpmirrordev added a subscriber: wpmirrordev.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 7 2015, 11:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 236818 had a related patch set uploaded (by Southparkfan):
chmod 644 for php files

https://gerrit.wikimedia.org/r/236818

Change 236818 merged by jenkins-bot:
chmod 644 for php files

https://gerrit.wikimedia.org/r/236818

I confirm that the above mentioned debian lintian warnings are cured.
Thanks.