Page MenuHomePhabricator

CX various problems
Closed, ResolvedPublic

Description

Here is a list of problems found by @Bgwhite

  1. [[1,1,1-tribromoethane]]

https://en.wikipedia.org/w/index.php?title=1,1,1-tribromoethane&oldid=680017798

  1. [[Pulikkottil Hyder]] - (1) nowiki tags in refs, around italics and around wikilinks. (2) Also has <ref><ref>

https://en.wikipedia.org/w/index.php?title=Pulikkottil_Hyder&action=edit&oldid=680108445

  1. [[Iris pharma]] - (1) Did not translate section headers. (2) Adding <br> at the end of items in an unordered list and inside external links. <br> was not present in the original article.

https://en.wikipedia.org/w/index.php?title=Iris_pharma&action=edit&oldid=680050505

  1. [[Ashok Dave]] - converted table into an empty table.

https://en.wikipedia.org/w/index.php?title=Ashok_Dave&action=edit&oldid=679939579

  1. [[Ajay Yadav]] - <div> tags including empty <div> tags.

https://en.wikipedia.org/w/index.php?title=Ajay_Yadav&action=edit&oldid=679925676

  1. [[Controversy about Korean Ministry of Gender Equality and Family]] - <div> tags including empty <div> tags.

https://en.wikipedia.org/w/index.php?title=Controversy_about_Korean_Ministry_of_Gender_Equality_and_Family&action=edit&oldid=679888386

  1. [[Kemal Kılıçdaroğlu]] - Vandalism edit. "Translated" a paragraph over a much, much longer article. I use quotes around translated because CX didn't translate the Turkish words.
  1. [[Ivo Nesrovnal]] - <br><br><br><br><br><br><br><br><br><br><br><br><br>

https://en.wikipedia.org/w/index.php?title=Ivo_Nesrovnal&action=edit&oldid=679765816

  1. [[A-TEC Industries]] - Didn't translate {{cite web}} parameters.

https://en.wikipedia.org/w/index.php?title=A-TEC_Industries&action=edit&oldid=679765780

  1. [[Zhang Jinan‎]] - (1) <span> tags inside <ref> tags. (2) Didn't translate section header.

https://en.wikipedia.org/w/index.php?title=Zhang_Jinan&action=edit&oldid=679763214&editintro=Template:BLP_editintro

  1. [[Eric Zhou]] - (1) <span> tags inside <ref> tags. (2) Didn't translate section header. (3) Has following wikilink: 《[[The Way We Were (TV series)|16個夏天》] (4) Uses 》for quoation marks and 。for periods.

https://en.wikipedia.org/w/index.php?title=Eric_Zhou&action=edit&oldid=679751002&editintro=Template:BLP_editintro

  1. [[Campanularia‎]] - (1) Didn't translate (2) Another reason to have CX

https://en.wikipedia.org/w/index.php?title=Campanularia&oldid=679749323

  1. [[Gunabati Union]] - (1) <span> tags inside <ref> tags. (2) <br> tags at end of unordered list items. (3) <br> tags at end of material in table cells. (4) an untranslated section header

https://en.wikipedia.org/w/index.php?title=Gunabati_Union&action=edit&oldid=679732408

  1. [[Hacienda El Tanque]] - (1) <span> tags everywhere. (2) {{template: (3) <nowiki> tags. (4) Didn't translate dates in cite templates.

https://en.wikipedia.org/w/index.php?title=Hacienda_El_Tanque&action=edit&oldid=679688285

Event Timeline

Magioladitis raised the priority of this task from to Needs Triage.
Magioladitis updated the task description. (Show Details)
Magioladitis added subscribers: Magioladitis, Bgwhite, NicoV.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 8 2015, 10:18 PM
Arrbee added a subscriber: Arrbee.Sep 9 2015, 6:25 AM

Here is a list of problems found by @Bgwhite

[[1,1,1-tribromoethane]]

https://en.wikipedia.org/w/index.php?title=1,1,1-tribromoethane&oldid=680017798

What is the problem exactly?

[[Pulikkottil Hyder]] - (1) nowiki tags in refs, around italics and around wikilinks. (2) Also has <ref><ref>
https://en.wikipedia.org/w/index.php?title=Pulikkottil_Hyder&action=edit&oldid=680108445

Some users type wiki syntax in translations, as they do in VisualEditor. When (maybe) some day we move our editing component from plain contenteditable to VisualEditor (T105447), it will get VE's tools for reducing this phenomenon, but even then it won't be bulletproof.

[[Iris pharma]] - (1) Did not translate section headers. (2) Adding <br> at the end of items in an unordered list and inside external links. <br> was not present in the original article.
https://en.wikipedia.org/w/index.php?title=Iris_pharma&action=edit&oldid=680050505

(1) The user didn't translate the section headers. The users are supposed to type the translation, especially when there is no machine translation (and even when there is, they should be verified). That said, we may some day do something clever about some section headings, see T105583. I also created T111900, so thanks for noticing this.
(2) <br> tags is already reported at T105447.

[[Ashok Dave]] - converted table into an empty table.
https://en.wikipedia.org/w/index.php?title=Ashok_Dave&action=edit&oldid=679939579

Doesn't look like a bug - the user probably pasted the table, but decided not to write anything in it, and then removed it in the next edit.

[[Ajay Yadav]] - <div> tags including empty <div> tags.
https://en.wikipedia.org/w/index.php?title=Ajay_Yadav&action=edit&oldid=679925676
[[Controversy about Korean Ministry of Gender Equality and Family]] - <div> tags including empty <div> tags.
https://en.wikipedia.org/w/index.php?title=Controversy_about_Korean_Ministry_of_Gender_Equality_and_Family&action=edit&oldid=679888386

Split to T111928.

[[Kemal Kılıçdaroğlu]] - Vandalism edit. "Translated" a paragraph over a much, much longer article. I use quotes around translated because CX didn't translate the Turkish words.

Indeed, just vandalism, can happen with anybody using the Edit button.

[[Ivo Nesrovnal]] - <br><br><br><br><br><br><br><br><br><br><br><br><br>
https://en.wikipedia.org/w/index.php?title=Ivo_Nesrovnal&action=edit&oldid=679765816

Weird... the only thing I can think of is that the user pressed Enter lots of times. I asked the translator: https://be-tarask.wikipedia.org/wiki/%D0%93%D1%83%D1%82%D0%B0%D1%80%D0%BA%D1%96_%D1%9E%D0%B4%D0%B7%D0%B5%D0%BB%D1%8C%D0%BD%D1%96%D0%BA%D0%B0:Belamp#Ivo_Nesrovnal

[[A-TEC Industries]] - Didn't translate {{cite web}} parameters.
https://en.wikipedia.org/w/index.php?title=A-TEC_Industries&action=edit&oldid=679765780

It's not {{cite web}}, but {{Internetquelle}}, which was (curiously!) designed specifically for translations from the German Wikipedia. And as far as I can see, all the parameters were translated. Am I missing anything?

[[Zhang Jinan‎]] - (1) <span> tags inside <ref> tags. (2) Didn't translate section header.
https://en.wikipedia.org/w/index.php?title=Zhang_Jinan&action=edit&oldid=679763214&editintro=Template:BLP_editintro

(1) I added T111930. Very curious.
(2) Same as above - might get resolved with T105583 Some Day.

[[Eric Zhou]] - (1) <span> tags inside <ref> tags. (2) Didn't translate section header. (3) Has following wikilink: 《[[The Way We Were (TV series)|16個夏天》] (4) Uses 》for quoation marks and 。for periods.
https://en.wikipedia.org/w/index.php?title=Eric_Zhou&action=edit&oldid=679751002&editintro=Template:BLP_editintro

I don't see any references at all,

[[Campanularia‎]] - (1) Didn't translate (2) Another reason to have CX
https://en.wikipedia.org/w/index.php?title=Campanularia&oldid=679749323

Lots of things in MediaWiki's UI make it unclear how and where to create an article, and that's how it was long before CX. https://en.wikipedia.org/wiki/Template:Not_English has existed since 2004 - more than ten years before CX, and it was used on a lot of articles (I'd guess that tens of thousands, maybe hundreds of thousands). The point is that it's a wiki and it happens quite a lot that people create articles in the wrong language. Does CX make it happen significantly more often?

[[Gunabati Union]] - (1) <span> tags inside <ref> tags. (2) <br> tags at end of unordered list items. (3) <br> tags at end of material in table cells. (4) an untranslated section header
https://en.wikipedia.org/w/index.php?title=Gunabati_Union&action=edit&oldid=679732408

(1) Thanks, I created T111935.
(2) See above.
(3) Thanks, I created T111937.
(2) See above.

[[Hacienda El Tanque]] - (1) <span> tags everywhere. (2) {{template: (3) <nowiki> tags. (4) Didn't translate dates in cite templates.
https://en.wikipedia.org/w/index.php?title=Hacienda_El_Tanque&action=edit&oldid=679688285

(1) Thanks, I created T111938.
(2) T98018.
(3) A known Parsoid problem, also affects VisualEditor.
(4) We don't translate template parameters. Maybe some day we'll allow editing them (T90160). In the particular case of dates, it would make much more sense if they were written as 2014-10-12, rather than in English or Spanish, at least in the transclusion.

  • [[1,1,1-tribromoethane]]

No content really to translate. It also misses sub/sup tags on the chemical formula.

As @Bgwhite wrote:

"I checked 20 articles. 2 were deleted. 2 were one liners. Therefore, 13 articles had problems out of 16."

And I am start to lose track of what I have reported, what is really fixed, what is fixed and will be ready in the next release, what is not a bug, et.

For us (me, @Bgwhite, @NicoV, et al.) who check wiki syntax this procedure is really painful.

Ryuch added a subscriber: Ryuch.Nov 12 2015, 2:45 AM
Restricted Application added subscribers: StudiesWorld, revi. · View Herald TranscriptNov 12 2015, 2:45 AM
Amire80 closed this task as Resolved.Jul 20 2016, 10:53 AM
Amire80 claimed this task.

Split to several bugs.