Page MenuHomePhabricator

TypeError: jQuery(...).filter(...).makeCollapsible is not a function
Closed, InvalidPublic

Description

1TypeError: jQuery(...).filter(...).makeCollapsible is not a function TypeError: jQuery(...).filter(...).makeCollapsible is not a function
2 at Object.eval (eval at <anonymous> (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:4:681), <anonymous>:4:531)
3 at fire (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:45:122)
4 at Object.self.fireWith [as resolveWith] (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:46:431)
5 at Object.deferred.(anonymous function) [as ready] (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:47:790)
6 at handlePending (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:159:895)
7 at markModuleReady (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:162:254)
8 at Object.<anonymous> (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:162:855)
9 at fire (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:45:122)
10 at Object.self.add [as done] (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:45:656)
11 at Object.promise.always (https://sv.wikipedia.org/w/load.php?debug=false&lang=sv&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=PUr9dIEB:46:874)

Event Timeline

Josve05a created this task.Sep 10 2015, 8:56 PM
Josve05a raised the priority of this task from to Needs Triage.
Josve05a updated the task description. (Show Details)
Josve05a added a project: Notifications.
Josve05a added a subscriber: Josve05a.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 10 2015, 8:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Any reason you think this is an Echo bug...?

Actually, no. But i pressed the notification-thingy and it just kept loading, and would not show my "thanks". I checked my colsole and this was there,

Please include that in your initial bug report in the future :-)

Sorry :p But I was pre-occupied. Was going to add it later, but since I was pinged...

Krinkle closed this task as Invalid.May 23 2016, 11:55 PM
Krinkle added a subscriber: Krinkle.

None of Flow, Echo or Thanks extensions call "makeCollapsible()" anywhere in their code base. Maybe this came from a gadget that calls makeCollapsible() but forgot to load that dependency (jquery.makeCollapsible) first?

Without a url or steps to reproduce, this report is not actionable.

Search for insource:makeCollapsible on sv.wikipedia.org:

  1. MediaWiki:Gadgets-definition: NavFrames[default|ResourceLoader|dependencies=jquery.makeCollapsible]|NavFrames.js
  2. MediaWiki:Gadget-NavFrames.js: $( '.NavFrame' ).not( '.Hidden' ).makeCollapsible(

Which looks fine.