Page MenuHomePhabricator

CX adds nowiki tags around external links
Closed, ResolvedPublic

Related Objects

StatusAssignedTask
OpenNone
OpenNone
ResolvedAmire80
ResolvedEtonkovidova
ResolvedNone
ResolvedAmire80
InvalidNone
OpenAmire80
DeclinedNone
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPginer-WMF
OpenNone
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPginer-WMF
Resolvedsanthosh
Resolveddchan
Resolvedsanthosh
Resolvedsanthosh
ResolvedNikerabbit
Opensanthosh
Resolvedsanthosh
ResolvedPginer-WMF
OpenNone
ResolvedPginer-WMF
InvalidNone
ResolvedPetar.petkovic
Resolvedsanthosh
Resolvedsanthosh

Event Timeline

Josve05a created this task.Sep 24 2015, 2:36 AM
Josve05a raised the priority of this task from to Needs Triage.
Josve05a updated the task description. (Show Details)
Josve05a added a project: ContentTranslation.
Josve05a added subscribers: Josve05a, NicoV.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 24 2015, 2:36 AM
Amire80 added a subscriber: Amire80.

The source page has this wiki syntax:

* http://www.imdb.com/name/nm0324409/
* http://www.barbaragoenaga.com/index2.html
* http://www.majos.es/detalle.php?id=16

The target had this:

== Références ==
*<nowiki> http://www.imdb.com/name/nm0324409/</nowiki>
*<nowiki> http://www.barbaragoenaga.com/index2.html</nowiki>
*<nowiki> http://www.majos.es/detalle.php?id=16</nowiki>

This is probably a Parsoid issue, and AFAIK VisualEditor fixes it on the VE side. So I'm wondering whether it can be fixed in Parsoid, or does it have to be fixed in CX. I really see no reason to add <nowiki> to otherwise unchanged text.

(All that said, it's always a good idea for the translators to improve the source article before translating. In this case, turning these links into links with titles in square brackets would have prevented this problem.)

Amire80 triaged this task as Medium priority.Sep 29 2015, 6:25 PM
Amire80 set Security to None.
Amire80 moved this task from Needs Triage to CX7 on the ContentTranslation board.
Amire80 added subscribers: cscott, santhosh.

This is probably a Parsoid issue, and AFAIK VisualEditor fixes it on the VE side. So I'm wondering whether it can be fixed in Parsoid, or does it have to be fixed in CX. I really see no reason to add <nowiki> to otherwise unchanged text.

This is not a Parsoid issue. This needs fixing in CX, just like it was fixed in VE. If Parsoid gets url-like text in the HTML, Parsoid is forced to add nowikis around it to maintain HTML rendering as the editor encountered it. If a url-like text needs to be emitted as a link in wikitext (url/ext/wiki), then the HTML needs to be the right kind of <a..>..</a> tag and that is the client's responsibility (VE, Flow, CX, .... ).

ssastry moved this task from Backlog to Non-Parsoid Tasks on the Parsoid board.Oct 6 2015, 3:29 AM
Amire80 moved this task from CX8 candidates to Bugs on the ContentTranslation board.

I cannot reproduce this any more, but I'll leave it open for a bit more testing, and close it by the end of CX7 if it doesn't come back.

Amire80 moved this task from Bugs to CX7 on the ContentTranslation board.Oct 15 2015, 10:01 PM

Nope, sorry, I can reproduce it. There was some network issue yesterday and MT or cxserver didn't work for me (I'm not sure what it was exactly). Now everything works, so this is still broken - external links go into nowiki.

Arrbee moved this task from Bugs to Check & Move on the ContentTranslation board.Nov 26 2018, 1:52 PM
Restricted Application added a subscriber: jeblad. · View Herald TranscriptNov 26 2018, 1:53 PM
Etonkovidova added a subscriber: Etonkovidova.EditedDec 13 2018, 1:24 AM

I checked with CX2 translation which has improved template matching - for translation to cawiki (which has matching templates) the templates for external links were were matched correctly without <nowiki> tags.

Re-checked in wmf.8. The reported translation en->fr is not possible due to an ongoing translation.
The source article Barbara Goenaga has templates in external links.

==External links==
*{{IMDb name|0324409|Bárbara Goenaga}}
*{{official website|http://www.barbaragoenaga.com}}

which were added to References section in the translated articles (not sure by manual editing or by automatic translation) that resulted in the following wiki markup:

== Références ==
*<nowiki> http://www.imdb.com/name/nm0324409/</nowiki>
*<nowiki> http://www.barbaragoenaga.com/index2.html</nowiki>
Etonkovidova closed this task as Resolved.Jan 6 2019, 6:24 PM
Etonkovidova claimed this task.

Marking the issue as 'Resolved' now since cx2 handles external links correctly.