Page MenuHomePhabricator

AbuseFilter in ukwiki
Closed, ResolvedPublic

Description

In Ukrainian Wikipedia (uk.wikipedia.org) AbuseFilter from 23 september works incorrectly. He must blocked for 2 hours, but from 23 september he blocked for 1 week. https://uk.wikipedia.org/wiki/%D0%A1%D0%BF%D0%B5%D1%86%D1%96%D0%B0%D0%BB%D1%8C%D0%BD%D0%B0:%D0%96%D1%83%D1%80%D0%BD%D0%B0%D0%BB%D0%B8/%D0%A4%D1%96%D0%BB%D1%8C%D1%82%D1%80_%D1%80%D0%B5%D0%B4%D0%B0%D0%B3%D1%83%D0%B2%D0%B0%D0%BD%D1%8C

The problem may be in https://gerrit.wikimedia.org/r/#/c/222566/ ?? Who can fix?

Details

Related Gerrit Patches:
operations/mediawiki-config : masterRestore previous custom AbuseFilter IP Block durations

Event Timeline

Green_Zero raised the priority of this task from to Normal.
Green_Zero updated the task description. (Show Details)
Green_Zero added a project: AbuseFilter.
Green_Zero added a subscriber: Green_Zero.
Restricted Application added subscribers: Luke081515, Aklapper. · View Herald TranscriptSep 26 2015, 3:10 PM
Se4598 added a subscriber: Se4598.

Which filter triggers the block? Google translate mentions it could be filter 41?
I can't see it because its private, but from the list entry it tags atm. I suppose blocking has been disabled.

This is possible caused by https://gerrit.wikimedia.org/r/240053 which sets the AnonBlock variable to a now non-null value so that it doesn't fall back to ukwiki's default 2 hours or respectively for other wiki's their value unless explicit set.

Will prepare a patch.

Restricted Application added a subscriber: Matanya. · View Herald TranscriptSep 26 2015, 6:27 PM

Change 241354 had a related patch set uploaded (by Se4598):
Restore previous AbuseFilter customs IP Block durations

https://gerrit.wikimedia.org/r/241354

Yes, it filter 41. Now he disabled (after wrong actions).

Change 241354 merged by jenkins-bot:
Restore previous custom AbuseFilter IP Block durations

https://gerrit.wikimedia.org/r/241354

Krenair closed this task as Resolved.Sep 27 2015, 3:52 PM
Krenair claimed this task.
Krenair reassigned this task from Krenair to Se4598.
Krenair set Security to None.
Restricted Application added a subscriber: Base. · View Herald TranscriptOct 12 2015, 3:33 PM