Page MenuHomePhabricator

Add missing documentation messages to translate extension
Closed, ResolvedPublic

Description

Add missing documentation messages to translate extension.

To reproduce

Note: Link will expire in 15 days. Jenkins deletes the page after 15 days.

Actual results

  • I get these errors

16:56:52 Running "banana:all" (banana) task
16:56:52 >> 24 messages lack documentation.
16:56:52 >> Message "translate-page-description-legend" lacks documentation.
16:56:52 >> Message "translate-edit-committed" lacks documentation.
16:56:52 >> Message "translate-edit-tmsugs" lacks documentation.
16:56:52 >> Message "translate-magic-cm-savefailed" lacks documentation.
16:56:52 >> Message "translate-magic-words" lacks documentation.
16:56:52 >> Message "translate-magic-notsaved" lacks documentation.
16:56:52 >> Message "translate-magic-saved" lacks documentation.
16:56:52 >> Message "translate-tag-category" lacks documentation.
16:56:52 >> Message "translate-langstats-incomplete" lacks documentation.
16:56:52 >> Message "translate-ls-noempty" lacks documentation.
16:56:52 >> Message "translate-languagestats-overall" lacks documentation.
16:56:52 >> Message "translate-ls-submit" lacks documentation.
16:56:52 >> Message "translate-mgs-nothing" lacks documentation.
16:56:52 >> Message "translate-manage-nochanges" lacks documentation.
16:56:52 >> Message "translate-manage-nochanges-other" lacks documentation.
16:56:52 >> Message "translate-manage-conflict-summary" lacks documentation.
16:56:52 >> Message "translate-manage-fuzzy-summary" lacks documentation.
16:56:52 >> Message "translate-js-history" lacks documentation.
16:56:52 >> Message "translate-js-support" lacks documentation.
16:56:52 >> Message "translate-js-support-title" lacks documentation.
16:56:52 >> Message "translate-search-languagefilter" lacks documentation.
16:56:52 >> Message "translate-search-nofilter" lacks documentation.
16:56:52 >> Message "log-description-translationreview" lacks documentation.
16:56:52 >> Message "translate-workflowgroup-label" lacks documentation.
16:56:52 >> The "ckb" translation has 1 blank translation:
16:56:52 >> The translation of "translate-submit" is blank.
16:56:52 >> 15 messages lack documentation.
16:56:52 >> Message "tpt-diff-old" lacks documentation.
16:56:52 >> Message "tpt-diff-new" lacks documentation.
16:56:52 >> Message "tpt-submit" lacks documentation.
16:56:52 >> Message "tpt-render-summary" lacks documentation.
16:56:52 >> Message "tpt-download-page" lacks documentation.
16:56:52 >> Message "pt-movepage-current" lacks documentation.
16:56:52 >> Message "pt-movepage-subpages" lacks documentation.
16:56:52 >> Message "pt-movepage-action-check" lacks documentation.
16:56:52 >> Message "pt-movepage-action-perform" lacks documentation.
16:56:52 >> Message "pt-movepage-started" lacks documentation.
16:56:52 >> Message "pt-deletepage-invalid-title" lacks documentation.
16:56:52 >> Message "pt-deletepage-list-pages" lacks documentation.
16:56:52 >> Message "pt-deletepage-list-other" lacks documentation.
16:56:52 >> Message "pt-deletepage-started" lacks documentation.
16:56:52 >> Message "pt-deletepage-intro" lacks documentation.
16:56:52 Warning: Task "banana:all" failed. Use --force to continue.

Expected results

  • the test should pass without it failing the banana check test in npm.

Event Timeline

Paladox created this task.Sep 28 2015, 7:07 PM
Paladox updated the task description. (Show Details)
Paladox raised the priority of this task from to Needs Triage.
Paladox added a subscriber: Paladox.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 28 2015, 7:07 PM

@siebrand and @Nikerabbit can I add you to this task please.

Paladox set Security to None.Sep 28 2015, 7:08 PM
Paladox removed subscribers: Nikerabbit, siebrand.
Nikerabbit triaged this task as Normal priority.Oct 1 2015, 7:32 AM
Nikerabbit added a subscriber: Nikerabbit.
Nemo_bis added a subscriber: Nemo_bis.

Paladox, you can also fix this by editing /qqq pages on translatewiki.net by the way. :)

I doint have edit rights there I did but got hem revoke but. I am not sure what to write for these messages.

Paladox updated the task description. (Show Details)Oct 1 2015, 4:16 PM
Paladox updated the task description. (Show Details)Nov 3 2015, 4:58 PM

I tried to reproduce but I got a 404.

Paladox updated the task description. (Show Details)Nov 3 2015, 5:14 PM

@StudiesWorld I have fixed link.

The links will expire since it is set at 30 days for npm. But the error is in the description.

Nikerabbit closed this task as Resolved.Mar 14 2016, 9:50 AM
Nikerabbit claimed this task.
> @ test /www/dev.translatewiki.net/docroot/w/extensions/Translate
> grunt test

Running "jshint:all" (jshint) task
>> 37 files lint free.

Running "jscs:src" (jscs) task
>> 37 files without code style errors.

Running "jsonlint:all" (jsonlint) task
>> 677 files lint free.

Running "banana:all" (banana) task
>> 715 messages checked.

Done, without errors.