Page MenuHomePhabricator

Missing WikiEditor panel when using IE 9
Closed, ResolvedPublic

Description

Hi, there seem to be occuring something similar to this previous problem
On cswiki with IE9 I have problems starting yesterday with loading edit panel. To be more precise, the panel does not load at all. When using F12 I can see following error SEC7115 I am no expert on programming and I am pretty disturbed by not being able to edit wikipedia properly. Feels like it is 1985 and not 2015.

Event Timeline

Davcza created this task.Sep 30 2015, 10:52 PM
Davcza claimed this task.
Davcza raised the priority of this task from to High.
Davcza updated the task description. (Show Details)
Davcza added a subscriber: Davcza.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 30 2015, 10:52 PM

Hi Davcza,

The CSS Extension project isn't deployed on Wikipedia so that can't be the cause.

The SEC7115 message is probably a red herring as well.

Can you try clearing your browser cache & cookies and see if that fixes it?

If not, can you provide additional details? What URL are you having trouble with? Can you attach a screenshot?

Hi, of course I cleared cache and cookies. I even updated Java and (possibly unnecessarily) deleted Mozilla Firefox from my laptop, only to make sure there is no interference. I would not contact phabricator if I suspected it is an ordinary/individual problem. The thing is, last week I suddenly came across similar problem at my other computer (IE8), so I am inclined to believe there is a wider problem with mediawiki vis-a-vis IE... As to my recent problem, it occures on all pages on Czech wikipedia. I am sending 2 screenshots of one article on cswiki and of the script.

Sorry, I am not able to upload files with the screenshots. It says just drag the files into the comment box. It does not work like that.

The screenshots are here

Aklapper raised the priority of this task from High to Needs Triage.Oct 1 2015, 10:02 AM

Also being discussed in https://cs.wikipedia.org/wiki/Wikipedie:Pod_lípou#zmizel_editační_panel

Is some anti-virus software like Avast installed? (I'm asking because of https://phabricator.wikimedia.org/T112110.) If yes: Does disabling that software and reloading the page fix the problem? (Please enable the software again after doing so.)

Does the same problem also happen with another browser (like Firefox)?

Could you open the browser's console (or whatever it is called in your browser) and reload the page while also bypassing your browser cache when reloading the page?
For more information please see: Internet Explorer / Firefox.

  • No, I do not use any anti-virus software...
  • The problem occurs only with IE (I downloaded Chrome, and there is no problem, however I wish to stick with IE)
  • Strange thing is also, that by opening a page on German wikipedia, the problem does not occur, while by opening Czech or English wikipedia the problem occurs,
  • bypassing browser´s cache (CTRL+F5) did not help
  • as to the console thing, I´d probably need Czech instructions. However when opening the F12 tool and clicking "konzola", I can see following message

"SEC7115: Styly :visited a :link se mohou lišit pouze barvou. Některé styly nebyly použity pro styl :visited.
index.php?title=Tommy_Lapid&action=edit"

Hope it will help you with diagnosis

I can confirm I had the same problem once (two days ago, on cswiki), using Firefox latest version. At the time, I thought the problem was slow Internet and thus slow loading of the panel. However I was able to click on the "panel" buttons even though there were no icons or button descriptions (it was blind). The problem solved itself after about 5-10 minutes of trying and I never had it since.

Aklapper renamed this task from Missing edit panel = problems with IE in compatibility mode? to Missing WikiEditor panel (in IE8 with compatibility mode?).Oct 1 2015, 11:56 AM

Trying to track down potential factors, what are your settings on https://cs.wikipedia.org/wiki/Speciální:Nastavení#mw-prefsection-editing for:

  • Show edit toolbar (Ukázat panel nástrojů při editaci)
  • Enable enhanced editing toolbar (Zapnout vylepšený panel nástrojů)
  • Temporarily disable the visual editor while it is in beta (Dočasně zakázat vizuální editor, dokud je ve verzi „beta“)

And does anything change if you enable/disable some of them?

  • Show edit toolbar (Ukázat panel nástrojů při editaci)
  • Enable enhanced editing toolbar (Zapnout vylepšený panel nástrojů)
  • Temporarily disable the visual editor while it is in beta (Dočasně zakázat vizuální editor, dokud je ve verzi „beta“)

First two checked, the third unchecked for me. I cannot replicate the problem so Davcza will have to tell us what happens when he fiddles with these settings.

Davcza added a comment.Oct 1 2015, 7:10 PM

sorry, I am at the moment not at my computer, so I cannot respond to your suggestions. Probably tommorow.

Davcza added a comment.Oct 1 2015, 8:04 PM

BTW, I tried to enable/disable those 3 parametres in my settings on wikipedia (I must stress that now I access internet from another computer - the one that since last week does show "blind" editing toolbar eg. without icons, which is slightly different and less troubling error than the other computer which does not show editing toolbar at all) and when I disable the "Enable enhanced editing toolbar /Zapnout vylepšený panel nástrojů" function the "blind" toolbar is replaced by fully functional "old" toolbar. But I repeat, that I will not be able to check the effect on my other computer untill tommorow.

I am able to reproduce this behavior on cswiki using IE11 with developer toolbar and IE9 emulation:

  1. Start an InPrivate session to be sure we start with a clean state.
  2. Press F12 to open the developer toolbar; there, enable IE9 emulation mode via the _Emulation_ tab or the button on the left-hand side of the toolbar caption. (Note that in IE10 emulation mode, everything seems to work fine. And in IE8 as well!?! Only IE9 (and IE7 and older) seems to be broken.)
  3. Go to e.g. https://cs.wikipedia.org/w/index.php?title=0&action=edit – you’ll get an edit screen without the toolbar. (As mentioned above, on de.wikipedia.org, everything seems fine.)
  4. Now, if you enable the debug mode with https://cs.wikipedia.org/w/index.php?title=0&action=edit&debug=true the toolbar is displayed. Obviously a ResourceLoader-related problem.

The direct cause of the missing toolbar is that the style module from jquery.wikiEditor.toolbar.less is not loaded, therefore the toolbar is there in DOM, but it is unstyled and hidden (because ext.wikiEditor.toolbar.styles.less gets loaded).

Why is that, I don’t know as I don’t really understand ResourceLoader and don’t know where to look.

Well, since it is a problem with IE9 and CSS, this might be some issue in the neighborhood of T108727: IE9 executing our MediaWiki:Print.css stylesheet in screen media and the fix for that bug.

@Schnark: I see… if ( document.documentMode === 9 ) kinda explains why the bug appears _only_ in IE9 mode, but not in IE10 nor IE8.

TheDJ added a subscriber: TheDJ.Oct 2 2015, 12:56 PM

Confirmed, if I switch documentMode to IE8 in IE9, then it seems that the scripts start working. If I take IE10 and switch documentMode to 9, then IE10 stops working.

My investigation of this is somewhat hampered by the fact that it works for me locally :(

Bah, I see why it doesn't work. This was a really stupid mistake on my part.

Change 243186 had a related patch set uploaded (by Bartosz Dziewoński):
Don't clobber existing styles when adding more in IE9

https://gerrit.wikimedia.org/r/243186

Change 243187 had a related patch set uploaded (by Ori.livneh):
Don't clobber existing styles when adding more in IE9

https://gerrit.wikimedia.org/r/243187

matmarex renamed this task from Missing WikiEditor panel (in IE8 with compatibility mode?) to Missing WikiEditor panel when using IE 9.Oct 2 2015, 3:02 PM
matmarex claimed this task.

Change 243187 merged by Ori.livneh:
Don't clobber existing styles when adding more in IE9

https://gerrit.wikimedia.org/r/243187

Merged, and Ori deployed the change. Again, I'm really sorry for breaking this, and it sucks that your report got lost for a few days. Thanks for filing this and poking me!

matmarex closed this task as Resolved.Oct 2 2015, 3:20 PM
matmarex triaged this task as High priority.
matmarex removed a project: Patch-For-Review.

Change 243192 had a related patch set uploaded (by Bartosz Dziewoński):
Don't clobber existing styles when adding more in IE9

https://gerrit.wikimedia.org/r/243192

Change 243186 merged by jenkins-bot:
Don't clobber existing styles when adding more in IE9

https://gerrit.wikimedia.org/r/243186

Change 243192 merged by jenkins-bot:
Don't clobber existing styles when adding more in IE9

https://gerrit.wikimedia.org/r/243192

GOIII moved this task from Backlog to Closed on the WikiEditor board.Apr 3 2016, 9:02 AM