Page MenuHomePhabricator

Fatal error: Invalid operand type was used: cannot perform this operation with arrays in /srv/mediawiki/php-master/extensions/PageImages/ApiQueryPageImages.php on line 39
Closed, ResolvedPublic

Description

On Beta Cluster Search suggestions are not displayed in Search field.

GET http://en.wikipedia.beta.wmflabs.org/w/api.php?action=opensearch&format=json&search=Talk%3AET&namespace=0&limit=10&suggest=true 503 
(Service Unavailable)jQuery.ajaxTransport.options.send @ load.php?
debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=HslbnM5S:140jQuery.extend.ajax @ load.php?
debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=HslbnM5S:13
4mw.loader.implement.mw.Api.ajax @ VM5414:36mw.loader.implement.mw.Api.get @ 
VM5414:35mw.loader.implement.mw.searchSuggest.request @ 
VM5417:373mw.loader.implement.$.suggestions.fetch @ VM5417:376maybeFetch @ VM5417:363

https://logstash-beta.wmflabs.org/#/dashboard/elasticsearch/fatalmonitor displays
Fatal error: Invalid operand type was used: cannot perform this operation with arrays in /srv/mediawiki/php-master/extensions/PageImages/ApiQueryPageImages.php on line 39

Event Timeline

Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova updated the task description. (Show Details)
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added subscribers: Luke081515, Aklapper. · View Herald TranscriptOct 1 2015, 8:20 PM
greg renamed this task from [betalabs] Search suggestions are not displayed: 503 Error to [betacluster] Search suggestions are not displayed: 503 Error.Oct 1 2015, 8:53 PM
greg updated the task description. (Show Details)
greg set Security to None.
greg edited projects, added Discovery; removed discovery-system.
Etonkovidova updated the task description. (Show Details)Oct 1 2015, 9:02 PM
greg renamed this task from [betacluster] Search suggestions are not displayed: 503 Error to Fatal error: Invalid operand type was used: cannot perform this operation with arrays in /srv/mediawiki/php-master/extensions/PageImages/ApiQueryPageImages.php on line 39.Oct 1 2015, 9:14 PM
greg triaged this task as Unbreak Now! priority.
greg added a project: PageImages.
greg added a subscriber: greg.

This is causing lots of 503s in Beta Cluster, setting to UBN!

See it here: https://logstash-beta.wmflabs.org/#dashboard/temp/AVAlQp9na1EjumVdsyEF

greg added a comment.Oct 1 2015, 9:18 PM

Started at 18:30 UTC today.

Krenair added a subscriber: Krenair.Oct 1 2015, 9:22 PM
greg assigned this task to Jdlrobson.Oct 1 2015, 9:23 PM

Most likely caused by https://gerrit.wikimedia.org/r/#/c/242835/ merged by Jon. Assigning to him

Change 243026 had a related patch set uploaded (by Legoktm):
Revert "Include foreign files in ApiQueryPageImages"

https://gerrit.wikimedia.org/r/243026

Change 243026 merged by jenkins-bot:
Revert "Include foreign files in ApiQueryPageImages"

https://gerrit.wikimedia.org/r/243026

greg added a subscriber: Ryasmeen.Oct 1 2015, 10:06 PM

@Etonkovidova / @Ryasmeen can you still reproduce this problem on Beta Cluster?

Change 243124 had a related patch set uploaded (by Phuedx):
Revert "Revert "Include foreign files in ApiQueryPageImages""

https://gerrit.wikimedia.org/r/243124

phuedx added a comment.Oct 2 2015, 9:13 AM

I've brought this into the Reading Web team's current sprint so that it's tested for when reviewing 243124. Do bear in mind that you'll need to add the following to your LocalSettings.php:

$wgPageImagesExpandOpenSearchXml = true;
greg added a comment.Oct 2 2015, 3:40 PM

(it has a patch for review)

Jdlrobson lowered the priority of this task from Unbreak Now! to High.Oct 5 2015, 5:41 PM

Change 243124 merged by jenkins-bot:
Include foreign files in ApiQueryPageImages

https://gerrit.wikimedia.org/r/243124

Jdlrobson closed this task as Resolved.Oct 6 2015, 11:17 PM
Jdlrobson added a subscriber: Jdlrobson.

Not seeing any fatals yet given the recently re-merged change. Will keep monitoring.