Page MenuHomePhabricator

http://wikia.com/ is blocking travis
Closed, ResolvedPublic

Description

The site_detect tests started failing to detect http://guildwars.wikia.com/ on October 5, 2015, and the 'wikia' builds also started skipping tests using the wikia site, reporting HTTP 403: You are not allowed to access this resource

https://travis-ci.org/wikimedia/pywikibot-core/builds/83661682

This has continued for two days now.

This has exposed an unrelated bug in cosmetic_changes (to be fixed in https://gerrit.wikimedia.org/r/#/c/244055/), where it was using the Wikia site instead of the intended site de.wikipedia, causing tests.cosmetic_changes_tests.TestCosmeticChanges.test_fixTypo to be a failure in the wikia builds.

Details

Related Gerrit Patches:
pywikibot/core : master[FIX] Remove guildwars test

Event Timeline

jayvdb created this task.Oct 5 2015, 10:27 AM
jayvdb raised the priority of this task from to Needs Triage.
jayvdb updated the task description. (Show Details)
jayvdb added projects: Pywikibot, Pywikibot-tests.
jayvdb added a subscriber: jayvdb.
Restricted Application added subscribers: pywikibot-bugs-list, Aklapper. · View Herald TranscriptOct 5 2015, 10:27 AM

It only started occurring today, and I could reproduce, so may be magically fixed in the next build.

jayvdb added a comment.Oct 5 2015, 8:53 PM

No, https://travis-ci.org/wikimedia/pywikibot-core/builds/83694572 failed on guildwars, but again I cant replicate it (using requests 2.7.0, which is the same as travis).

On travis, guildwars errors with : RuntimeError: Unsupported url: http://guildwars.wikia.com/wiki/

XZise added a subscriber: XZise.Oct 5 2015, 9:46 PM

Okay because I thought this site might actually block Travis somehow I just ran that test with just that URL and included a bit of debug output. This is the result:

Test detection of MediaWiki sites. ... WARNING: Http response status 403
403
 You are not allowed to access this resource

The second line is the HTTP status code and the third line the actual content returned by the site.

Change 243822 had a related patch set uploaded (by XZise):
[FIX] Remove guildwars test

https://gerrit.wikimedia.org/r/243822

Change 243822 merged by jenkins-bot:
[FIX] Remove guildwars test

https://gerrit.wikimedia.org/r/243822

jayvdb renamed this task from site detection of http://guildwars.wikia.com/ fails to http://wikia.com/ is blocking travis.Oct 6 2015, 9:47 PM
jayvdb triaged this task as Unbreak Now! priority.
jayvdb updated the task description. (Show Details)
jayvdb removed a project: Patch-For-Review.
jayvdb set Security to None.
jayvdb added a subscriber: Grunny.
jayvdb added a subscriber: PMG.

Network-wise, where are you running this from?

jayvdb added a subscriber: Inez.

Network-wise, where are you running this from?

Hi, thanks for the quick response. We are seeing 403's when our compatibility tests are run on http://travis-ci.org, but not when run elsewhere.

Sorry for the mass-subscribes.
Feel free to un-subscribe; I was just adding any names I recognise as someone close to Wikia who might be able to help.
We normally also create a ticket upstream, and cross-link them. Where should we create a ticket for issues related to Wikia?

@jayvdb thanks. We have changed some network settings; I'll let our ops team know.

I think this should work now. I see that it failed on the last build 32 min ago, but I think the network problems are now resolved based on a change we just made.

The 403s are gone, but for some reason my last job failed to login as JVbot-test.
https://travis-ci.org/jayvdb/pywikibot-core/jobs/85006135

XZise closed this task as Resolved.Oct 13 2015, 2:32 PM