Page MenuHomePhabricator

Importing an article from different language Wikipedia displays incorrect byte sizes for diffs in History
Closed, ResolvedPublic

Description

Hi! The problem is about the revision history of imported pages across wikimedia projects in all languages.

For example:

https://de.wikipedia.org/w/index.php?title=Silver_Falcons&action=history

as this entries:

  • (cur | prev) 2014-11-01T16:12:55‎ Farawayman (Talk | contribs | block)‎ . . (11,474 bytes) (+6,296)‎ . . (→‎Current team: added "outdated" banner to section) (undo | thank)
  • (cur | prev) 2014-03-27T15:01:28‎ Nathan121212 (Talk | contribs | block)‎ . . (11,449 bytes) (+6,271)‎ . . (→‎Team 73) (undo | thank)
  • (cur | prev) 2014-03-24T05:49:59‎ NJR ZA (Talk | contribs | block)‎ . . (11,466 bytes) (+6,288)‎ . . (removed Category:Aerobatic teams; added Category:South African aerobatic teams using HotCat) (undo | thank)
  • (cur | prev) 2014-03-20T20:05:10‎ Nathan121212 (Talk | contribs | block)‎ . . (11,452 bytes) (+6,274)‎ . . (undo | thank)
  • (cur | prev) 2014-03-17T16:03:27‎ Nathan121212 (Talk | contribs | block)‎ . . (11,416 bytes) (+6,238)‎ . . (undo | thank)
  • (cur | prev) 2014-03-17T15:59:58‎ Nathan121212 (Talk | contribs | block)‎ . . (11,387 bytes) (+6,209)‎ . . (→‎Current team) (undo | thank)

Look at the revision sizes and the diff sizes and tell me please, how 11,416 bytes + 6,274 can be 11,452 bytes.

Is it a bug in the mediawiki software due to importing pages from somewhere else into existing articles?

Delete and undelete the article after the import cleans up the revision sizes in the history, but deletes resp. destroys logs in the logbooks, this is no solution of the problem.

Thank you very much ...

Details

Related Gerrit Patches:
mediawiki/core : masterSet correct parentid on import

Event Timeline

doctaxon created this task.Oct 6 2015, 9:04 PM
doctaxon assigned this task to Aklapper.
doctaxon raised the priority of this task from to High.
doctaxon updated the task description. (Show Details)
Ireas added a subscriber: Ireas.Oct 6 2015, 9:07 PM
Aklapper raised the priority of this task from High to Needs Triage.Oct 7 2015, 12:03 PM

Thanks for taking the time to report this!

Look at the revision sizes and the diff sizes and tell me please, how 11,416 bytes + 6,274 can be 11,452 bytes.

Looks like the calculation mistakenly refers to the revision from Oct 4th which has 5.178 bytes.
https://de.wikipedia.org/w/index.php?title=Silver_Falcons&type=revision&diff=146645073&oldid=146669452 is the import from en.wp presumably.

(Resetting priority of this task to its default - I don't see yet how this it's an urgent problem and why it is important for your work to have correct diff byte sizes for the important English versions but feel free to elaborate)

Aklapper renamed this task from Bug in MediaWiki-Import of revisions into existing articles to Importing an article from different language Wikipedia displays incorrect byte sizes for diffs in History.Oct 7 2015, 12:05 PM
Aklapper removed Aklapper as the assignee of this task.
Aklapper added a project: MediaWiki-Page-Diffs.
Aklapper set Security to None.
Aklapper added a subscriber: Aklapper.
doctaxon assigned this task to Aklapper.

Errm... why was this assigned to me? Removing myself as assignee.

Man77 added a subscriber: Man77.Oct 7 2015, 5:19 PM

Change 244496 had a related patch set uploaded (by Umherirrender):
Set correct parentid on import

https://gerrit.wikimedia.org/r/244496

Change 244496 merged by jenkins-bot:
Set correct parentid on import

https://gerrit.wikimedia.org/r/244496

Umherirrender closed this task as Resolved.Oct 10 2015, 5:41 AM
Umherirrender claimed this task.