Page MenuHomePhabricator

Look into which Collab members need visas for the Sweden meeting
Closed, ResolvedPublic

Event Timeline

FloorKoudijs assigned this task to Selsharbaty-WMF.
FloorKoudijs raised the priority of this task from to High.
FloorKoudijs updated the task description. (Show Details)
FloorKoudijs moved this task from Backlog to Claimed / in progress on the Education-Collab board.

I'm hoping @Vojtech.dostal would be willing and able to serve as an advisor to Sara and Samir on this task, based on his own experience organizing the first Collab meeting in Prague. Vojtech, let us know if that would work or if you're not able to help with this. Thanks!

Yeah the advice is: start early :-). At least 3 months early. This is not about the speed of authorities in Sweden. Usually the most serious problems arise at the [in this case Swedish] consulates where people ask for the visa. It takes time and brings about a lot of confusion and bureaucracy.

Often people will need an invitation letter from the organizer to enable the visa process. In my case the letter had to be approved by the Czech Foreign Police and I had to prove that I have enough money on my account to take care of the visitors in case they run out of money. If the process is the same in Sweden, you'll probably need a Swedish organizer who'll have enough money on his/her account or be an official representative of some sort (details may differ case-by-case in each country and for each country and you need to find them out as early as possible).

Sweden is a modern country so maybe there could be an electronic (internet) method of filing the requests.

Start by going through the list of foreign citizens who require Visa for entry into Sweden
http://www.government.se/government-policy/migration/list-of-foreign-citizens-who-require-visa-for-entry-into-sweden/

Here is the official page by the Swedish Migration Agency which details how to apply and what is needed, all in English of course. http://www.migrationsverket.se/English/Private-individuals.html

That's great advice Vojtech, thanks for responding so quickly! We may turn to you later for further details, but this is a great first start. Since we are well in time with the planning I am optimistic about us being able to get this arranged well in advance, and your advice is even further encouragement to do so! :)

@Josve05a thanks for the link!

Briefly looking into the page dedicated to conference travels, it seems to be a little less complicated than in the Czech Republic, especially the invitation letter is moreless simple to write.

Welcome to @Josve05a. Thanks to @Vojtech.dostal. Just noting that @dungodung has experience convening international guests for EduWiki and could be good advisor to this task as well.

To tackle this problem, I guess you first need to know who the participants will be. Most people from Europe don't need a visa (Serbia included), so a bunch of work is done. What we can do is make a list of all potential participants, that might be trimmed later (because of the conditions of activity), so we could have an overview of roughly how many participants would need a visa.

Thanks for your input @Vojtech.dostal, @dungodung and @Josve05a.

@Vojtech.dostal The plan was to get members invited by early December, and encourage them to apply for visas before the Christmas holiday. Do you think if people manage to apply by early December, visas will be ready for pick up by mid February, i.e. at least two weeks before they leave? We don't want our valuable members to spend the last couple of hours before their flights at the embassies/consulates. We may also take into consideration that there would be some backlog at the embassies/consulates because of the holidays.

Base added a subscriber: Base.Oct 10 2015, 9:02 PM
Selsharbaty-WMF closed this task as Resolved.Dec 16 2015, 5:10 PM
Selsharbaty-WMF set Security to None.

All members confirmed whether they will/will not need a visa for the trip to Sweden. Requested support for visa applications was provided as needed.