[Alpha 5.0.0 (372)] ToC displays identical items
Closed, ResolvedPublic

Description

  1. Go to 'List of most massive black holes' article
  2. ToC is displayed:

NOTE
The article in wiki does not have ToC. Should articles in the apps always display ToC even though the article may have

__NOTOC__

in Page settings?

Acceptance Criteria:

Table of Contents View
Given that the table of contents overlay is visible for article with $title
When I see the first item in the table of contents
Then it should be the $title

Etonkovidova updated the task description. (Show Details)
Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova added subscribers: Aklapper, Etonkovidova.

@Etonkovidova @JMinor the legacy app shows the TOC on this page (see below), so I say we stick w/ that behavior. However, it shouldn't be hard to detect that page property and honor it in the app.

I'll look into a fix for this now.

@Etonkovidova @JMinor "This is a feature, not a bug." This article actually has a section called "Introduction." We just so happen to also refer to the article's lead section as its "Introduction." So, we can either adopt the legacy app behavior of showing the title instead (see last comment for a screenshot) or something less likely to collide w/ an actual section name.

Android displays ToC without 'Introduction':

'List of most massive black holes' article

To reiterate IRC convo for @JMinor: Android shows the article title instead of "Introduction," and scrolls to top when the title is tapped. In our case, users can also tap the status bar (when visible) to scroll to the top of the article (when ToC isn't visible).

BGerstle-WMF set Security to None.

@Etonkovidova @JMinor I moved this to "Needs Triage" since it needs to be triaged and it's not ready for dev (since no solution is prescribed in the ticket).

JMinor triaged this task as Low priority.Oct 14 2015, 5:43 PM

Suggest we use the article title. Partly to match Android, but also b/c there are weird potential language and localization issues here.

Mhurd claimed this task.
JMinor updated the task description. (Show Details)Oct 22 2015, 9:53 PM

Checked with 5.0.0.434 on iPhone 5 iOS 9.02

Note: The article title is not different from other ToC items.

JMinor closed this task as Resolved.Nov 18 2015, 8:46 PM

Related refinements to ToC happening on T113549