Page MenuHomePhabricator

Selecting Chinese (either variant) from the "Other languages" menu in non-main namespace pages gives wrong names and leads to an error page
Closed, ResolvedPublic

Description

Note this is only occurring when switching to a Chinese language variant in Other languages from the page, when a different language is selected (eg Deutsch, the correct corresponding page is shown)

Steps to reproduce
  1. Search for "WP:VPT" in English and I'm sent to page "Wikipedia:Village pump (technical)"
  2. Open the menu; choose "Read in other languages" and scroll to the zh-hans ("简体") option, noting the name of the page in Simplified Chinese
  3. Tap on the entry
Expected
  • In step 2, the correct corresponding title is "维基百科:互助客栈/技术" with Language Converter applied
  • In step 3, user should be taken to the 维基百科:互助客栈/技术 page
Actual
  • In step 2, the page title in this list item is shown as "互助客栈/技术" (missing the Simplified Chinese name for Wikipedia at the start of the title)
  • In step 3, user is sent to an error screen:

Occurring on

Still occurring on v2.7.255-r-2018-02-06 (Originally filed in version 2.1.134-r-2015-11-12)

Details

Event Timeline

liangent created this task.Oct 12 2015, 4:19 PM
liangent raised the priority of this task from to Needs Triage.
liangent updated the task description. (Show Details)
liangent added a subscriber: liangent.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 12 2015, 4:19 PM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 18 2015, 8:18 PM
Dbrant added a subscriber: Dbrant.Nov 18 2015, 8:20 PM

@liangent Can you provide a specific example of a page where this happens?

liangent updated the task description. (Show Details)Nov 18 2015, 10:09 PM

@liangent Can you provide a specific example of a page where this happens?

I added description for steps to reproduce.

liangent updated the task description. (Show Details)Nov 18 2015, 10:11 PM
Niedzielski triaged this task as Medium priority.Nov 9 2016, 7:56 PM
Niedzielski added a project: Android-app-Bugs.
Niedzielski added a subscriber: Niedzielski.

Both the title and page existence issues are still present on 7a04741abae79b23a9e590d969c1d559acf28132.

RHo renamed this task from Read in other languages gives wrong page names (with namespace missing) for pages in non-main namespaces to Selecting Chinese (either variant) from the "Other languages" menu in non-main namespace pages gives wrong names and leads to an error page.Mar 30 2018, 2:32 PM
RHo updated the task description. (Show Details)

Change 472751 had a related patch set uploaded (by Cooltey; owner: Cooltey):
[apps/android/wikipedia@master] Fix: Chinese variants issues that title in the lists does not match the article itself

https://gerrit.wikimedia.org/r/472751

Change 472751 abandoned by Dbrant:
Fix: Chinese variants issues that title in the lists does not match the article itself

Reason:
currently on github

https://gerrit.wikimedia.org/r/472751

cooltey claimed this task.Aug 31 2019, 12:35 AM
cooltey added a subscriber: cooltey.

Looks like this issue has been resolved recently.
@liangent please let us know if you still can see this issue on the latest version of the app.

Dbrant closed this task as Resolved.Nov 1 2019, 2:23 PM