Page MenuHomePhabricator

ContentTranslation fails with Internal server error if an invalid title is given
Closed, ResolvedPublic

Description

Try typing a URL with a page parameter that has an invalid title character, for example page=Hel}lo.

For example: https://en.wikipedia.org/wiki/Special:ContentTranslation?page=Steve+A}lbini&from=en&to=he

In production Wikipedia this produces Exception encountered, of type "BadMethodCallException".

On my local machine, this produces a blank page and the server log says: PHP Fatal error: Call to a member function getDBkey() on null in /home/amire80/dev/livowiki/extensions/ContentTranslation/specials/SpecialContentTranslation.php on line 69

Unless a URL is typed manually, this is unlikely to actually happen because the page selector validates the titles, but should probably be handled.

A similar frontend issue: T111544.

Event Timeline

Amire80 created this task.Oct 13 2015, 10:43 AM
Amire80 raised the priority of this task from to Low.
Amire80 updated the task description. (Show Details)
Amire80 added a subscriber: Amire80.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 13 2015, 10:43 AM
Nikerabbit closed this task as Resolved.May 10 2016, 8:21 AM
Nikerabbit claimed this task.

Not reproducible anymore.