Page MenuHomePhabricator

Adding Categories makes Board description unavailable for editing
Closed, ResolvedPublic

Description

  1. Click on 'Edit description' and add some Categories to an empty Board description, e.g.

[[Category:Test]]
[[Category:1687 deaths]]
[[Category:Exclude in print]]

  1. Click 'Save description' . The following errors will be displayed:
Uncaught TypeError: Cannot read property 'bind' of undefinedmw.loader.implement.mw.flow.ui.BoardDescriptionWidget.onEditorSaveContent @ VM1776:312mw.loader.implement.oo.EventEmitter.emit @ VM1776:189mw.loader.implement.mw.flow.ui.EditorWidget.onEditorControlsWidgetSave @ VM1776:306mw.loader.implement.oo.EventEmitter.emit @ VM1776:189mw.loader.implement.oo.EventEmitter.emit @ VM1776:189OO.ui.mixin.ButtonElement.onClick @ load.php?debug=false&lang=en&modules=oojs-ui|oojs-ui.styles.icons%2Cicons-editing-advanced&skin=vec…:48jQuery.event.dispatch @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=sQ8du77j:65jQuery.event.add.elemData.handle @ load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=sQ8du77j:60


Uncaught TypeError: this.board.hasCategories is not a function mw.loader.implement.mw.flow.ui.BoardDescriptionWidget.showContent
  1. Click on 'Edit description' again - the CE never finishes loading:

If you refresh the page and switch to VE and back to wikitext:

Event Timeline

Etonkovidova updated the task description. (Show Details)
Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 13 2015, 10:22 PM

I can't reproduce this at all in master... is this still happening?

Closing according to Elena.

Mooeypoo closed this task as Resolved.Oct 15 2015, 10:22 PM

Checked in betalabs.