Page MenuHomePhabricator

Display definitions of highlighted words from Wiktionary
Closed, ResolvedPublic

Description

Definition Progress

The following is a checklist for completion of the definition of the Epic. Make sure to check these off as you complete each item.

  • Summary
  • Rationale
  • Success Metrics
  • External Dependencies
  • Unknowns
  • Product Plan
    • Prototyping
    • MVP
    • User stories
    • User Story Phab Tickets
    • Metrics Implementation
    • Metrics Phab Tickets
    • Estimates
    • Delivery Date

Summary

When the user highlights a word or phrase while reading an article, the app will pop up a (non-modal) window that contains a definition of the word from Wiktionary.

Goal Visibility

Reading internal goal.

Rationale

Taking an example from link previews (which are useful for providing a quick definition of linked articles), this will provide a convenient definition of any highlighted word, without the need for the user to leave the app to look the word up. This will also provide a good example of cross-wiki-project integration, considering that Wiktionary content will be integrated seamlessly in a primarily-Wikipedia product.

Success Metrics

External Dependencies

This depends on the robustness of the existing Wiktionary API, and any deficiencies in this API to be addressed before work on this task is completed.

Unknowns

It's not yet certain whether the app will interface with the Wiktionary API directly, or if the app will only query the Content Service which will interface with Wiktionary itself.

Product Plan

Prototyping

Prototypes to be provided by Design.

MVP

The Wiktionary definition window should contain a concise definition of the highlighted word or phrase. Ideally this should be rendered natively (without the need for a WebView).

Metrics Implementation

Timeline Estimate

TaskEstimate
Prototyping1 week
User Testing2 weeks
Mockups2 weeks
Development2 weeks
Beta Testing1 week

Delivery Estimate

EOQ2

Event Timeline

Dbrant created this task.Oct 14 2015, 3:36 PM
Dbrant raised the priority of this task from to Needs Triage.
Dbrant updated the task description. (Show Details)
Dbrant added projects: Mobile-App-Goals, Epic.
Dbrant moved this task to Q2 Android on the Mobile-App-Goals board.
Dbrant added a subscriber: Dbrant.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 14 2015, 3:36 PM
dr0ptp4kt set Security to None.
dr0ptp4kt moved this task from Backlog to Current Quarter on the Reading-Admin board.
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 16 2015, 3:39 PM
Danny_B added a subscriber: Danny_B.
Dbrant closed this task as Resolved.Apr 14 2016, 6:37 PM
Dbrant claimed this task.