Page MenuHomePhabricator

ContentTranslation doesn't auto-save and doesn't publish images without captions
Closed, ResolvedPublic

Description

Hi!

I've created my first translation of part of an article using ContentTranslator tool. It looks like this in tool itself: https://i.imgur.com/JbOL853.png , but unfortunately, after I press "publish", I don't see images in translation. Here's the published article: https://uk.wikipedia.org/wiki/%D0%A7%D0%B8%D1%81%D0%B5%D0%BB%D1%8C%D0%BD%D0%B5_%D0%B4%D0%B8%D1%84%D0%B5%D1%80%D0%B5%D0%BD%D1%86%D1%96%D1%8E%D0%B2%D0%B0%D0%BD%D0%BD%D1%8F

Is there something wrong I did or is this a bug?

Thank you!

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterFix conditions that check whether a section should be saved

Event Timeline

ko_bx created this task.Oct 14 2015, 3:41 PM
ko_bx raised the priority of this task from to Needs Triage.
ko_bx updated the task description. (Show Details)
ko_bx added a project: ContentTranslation.
ko_bx added a subscriber: ko_bx.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 14 2015, 3:41 PM

That looks intentional to me. The image https://en.wikipedia.org/wiki/File:Derivative.svg is hosted on English Wikipedia and not on Wikimedia Commons, hence local laws apply and I'd say it's safer not just make some software copy stuff.

Aklapper renamed this task from Images are not shown in articles, created by ContentTranslator tool to Image from en.wp not copied over when creating article via ContentTranslator tool.Oct 14 2015, 4:11 PM
Aklapper set Security to None.
ko_bx added a comment.Oct 14 2015, 4:22 PM

Sure, copying it over would be a sensible solution to me.

Amire80 renamed this task from Image from en.wp not copied over when creating article via ContentTranslator tool to ContentTranslation doesn't auto-save and doesn't publish images without captions.Oct 15 2015, 7:35 AM
Amire80 triaged this task as Medium priority.
Amire80 added a project: WorkType-Maintenance.
Amire80 added a subscriber: Amire80.

Confirmed. It's a bug. Thanks for reporting (and for translating!).

This issue is very similar to T108461, but in that case it is possible to get an image saved if a caption is typed, and in cases of this kind, it's completely impossible, because the text is always empty.

Change 246666 had a related patch set uploaded (by Amire80):
Fix conditions that check whether a section should be saved

https://gerrit.wikimedia.org/r/246666

Amire80 moved this task from Needs Triage to CX7 on the ContentTranslation board.Oct 15 2015, 9:00 AM

Change 246666 merged by jenkins-bot:
Fix conditions that check whether a section should be saved

https://gerrit.wikimedia.org/r/246666

ko_bx added a comment.Oct 17 2015, 8:48 PM

@Amire80 update on the issue! It's not image which is not copied (although, I believe I didn't check), but it's mathematical formulas. They're displayed as images in editor, but truly they are math furmulas. I noticed that when I started editing source code.

Amire80 closed this task as Resolved.Nov 1 2015, 11:03 AM
Amire80 moved this task from Backlog to Done on the LE-CX7-Sprint 1 board.Nov 1 2015, 11:18 AM