Page MenuHomePhabricator

MediaViewer intermittent image loading errors (2015 Oct-Dec)
Closed, InvalidPublic

Description

There has been a number of error reports recently (first report was 2015-11-12) about MediaViewer showing the error page when trying to view an image. The errors are not reproducible, but seem to happen frequently for the affected users.

Based on developer toolbar screenshots, there are two different types of error:

Details

Related Gerrit Patches:
mediawiki/extensions/MultimediaViewer : masterIgnore case in file extension checks

Related Objects

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes
Krinkle added a subscriber: aaron.Oct 24 2015, 4:11 PM

So is there a fix for this or what? This only started happening within the last few weeks or so on Chrome Windows 10.

Blazeaglory added a comment.EditedOct 26 2015, 3:35 AM

Also, it will not open when clicked on directly from wikipedia but does work when clicked on "more details" AFTER clicking directly (when error image is displayed)...Then all of a sudden I can view the image normal BUT then that temp fix only works some of the time

PLEASE: The problem is solved. Stop sending me e-mails. Thanks

In a message dated 10/25/2015 5:41:20 P.M. Pacific Daylight Time,
no-reply@phabricator.wikimedia.org writes:

Tgr added subscribers: Blazeaglory, Zusurs, JTocornal.
Tgr merged tasks: T116543: When I open photos, says an error occurred or I
do not have permission, T116486: Picture missing, T116116: image does not
show.

TASK DETAIL
https://phabricator.wikimedia.org/T115563

EMAIL PREFERENCES
https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Tgr
Cc: JTocornal, Zusurs, Blazeaglory, aaron, David_Vanbellinghen,
Vladissimo18, Henrik9102, Pollti, brion, Matanya, Steinsplitter, jeremyb,
DanielScher, Cumboto, A_Jerv, MZMcBride, Neta1991, Adrewc, Vamps222, Bfeinbe,
Aklapper, Tgr, Bawolff, Fabrice_Florin

PLEASE: The problem is solved. Stop sending me e-mails. Thanks

In a message dated 10/25/2015 8:35:31 P.M. Pacific Daylight Time,
no-reply@phabricator.wikimedia.org writes:

Blazeaglory added a comment.

Also, it will not open when clicked on directly from wikipedia but does
work when clicked on "more details" AFTER clicking directly (when error image
is displayed)...Then all of a sudden I can view the image normal

TASK DETAIL
https://phabricator.wikimedia.org/T115563

EMAIL PREFERENCES
https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Blazeaglory
Cc: JTocornal, Zusurs, Blazeaglory, aaron, David_Vanbellinghen,
Vladissimo18, Henrik9102, Pollti, brion, Matanya, Steinsplitter, jeremyb,
DanielScher, Cumboto, A_Jerv, MZMcBride, Neta1991, Adrewc, Vamps222, Bfeinbe,
Aklapper, Tgr, Bawolff, Fabrice_Florin

Tgr removed a subscriber: Bfeinbe.Oct 26 2015, 4:29 AM
Blazeaglory added a comment.EditedOct 26 2015, 4:45 AM

I dont understand how it is fixed? Can you please tell me? And the system sends emails automatically, I do not send them myself...

It is not fixed on my end. Still having same issue

For me problem is solved , thank you for your work

Trimis din Yahoo Mail pe Android

De la:"Blazeaglory" <no-reply@phabricator.wikimedia.org>
Data:Lu 26 oct. 2015 la 6:45
Subiect:[Maniphest] [Commented On] T115563: MediaViewer intermittent image loading errors (2015 Oct)

Blazeaglory added a comment.

I dont understand how it is fixed? Can you please tell me?

TASK DETAIL
  https://phabricator.wikimedia.org/T115563

EMAIL PREFERENCES
  https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Blazeaglory
Cc: JTocornal, Zusurs, Blazeaglory, aaron, David_Vanbellinghen, Vladissimo18, Henrik9102, Pollti, brion, Matanya, Steinsplitter, jeremyb, DanielScher, Cumboto, A_Jerv, MZMcBride, Neta1991, Adrewc, Vamps222, Aklapper, Tgr, Bawolff, Fabrice_Florin

Change 248813 had a related patch set uploaded (by Gergő Tisza):
Ignore case in file extension checks

https://gerrit.wikimedia.org/r/248813

Ok in English how can we fix it? I am not a developer

I have been using Chrome and wikipedia for roughly a decade, why did this just happen within the last few weeks?

Once again, in simple English response, what is the problem and how can I fix it?

Tgr added a comment.Oct 26 2015, 7:00 AM

If I knew that, I would have fixed it already :)

Here is something you can try: before clicking on a thumbnail, open the developer console (F12), copy this line and press Enter:

mw.loader.using('mmv', function() { mw.mmv.provider.Image.prototype.imagePreloadingSupported = function() { return false; }; });

and see if the image still refuses to load afterwards.

haha I feel ya. If you are working on this, thanks for the help! And to the others as well!

It is very sporadic. Sometimes it happens, other times no.

Ill try that and get back to you

Blazeaglory added a comment.EditedOct 26 2015, 7:11 AM

No. It opens image for a second or two and then reverts back to same error image

EDIT: Now, I "retry" and sure enough, the images load. Ill see how long this last but for now it seems fixed. Maybe it was that line or the patch?

Tgr updated the task description. (Show Details)Oct 26 2015, 7:27 AM
Tgr added a comment.Oct 26 2015, 7:56 AM

The patch is for another error (and not deployed yet) and the mw.loader.using... snippet only works until you reload the page / load a new page. The error is nondeterministic, it doesn't affect most people at all and affects a few people but not 100% of the time - you'll probably see it again after a while. I'm trying to find a way to get more information about it but it will probably take some time.

I am also experiencing another issue as well.

When I click on the key or glossary in wiki (the top left where you can jump to sections), sometimes when I click on a section it will not jump, it only flashes but keeps me in the exact same spot.

Dont know if that has anything to do with it.

Also, when I get that error for the thumbnail, I can click on "more info" (little red button) and I can view the image just fine and then most of the time after that I can view the thumbnail just fine as well.

Change 248813 merged by jenkins-bot:
Ignore case in file extension checks

https://gerrit.wikimedia.org/r/248813

TTO added a subscriber: TTO.Oct 27 2015, 9:18 AM

I found http://stackoverflow.com/questions/33209454/adsense-resource-not-found-error-400ok, which is another person complaining about an intermittent 400 OK response showing up in Chrome. Notice that it was asked on 19 Oct. So perhaps this is some kind of intermittent bug in new versions of Chrome.

Also note that Chrome 46 came out on 13 Oct, the description of this task says first reports came in 12 Oct. Taking into account a possible timezone discrepancy, it makes you wonder...

Zusurs added a comment.EditedOct 27 2015, 9:20 AM

you will have to provide more information.

  • What operating system and browser did you use?

Problem seen on all my home and work PCs - all running latest Chrome 46 (Adblock and AdblockPlus extensions installed), Windows 8.1 and Windows 10, all PCs with i5/i7 CPUs, all have 16GB of RAM.

  • Were you logged in to Wikipedia while viewing the images?

Yes. I logged out to test, but problem still persisted.

  • Does this affect every image?

No, problems shows up now and then, once or twice a week at random pages. Sometimes thumbnail is missing as well, but most of the times thumbnail is ok, but error is shown when trying to open image in media viewer. It seems that returning to old style image view (clicking on link in lower right side of the Wikipedia Media Viewer screen) shows the image without problem.

  • Does this always affect the same image if you reload the page multiple times?

Yes.

  • Are you behind a proxy, company firewall, school network or similar?

No, fast optical direct broadband internet connection - used this provider for years, but problem with wikipedia images only showed up last six months or so.

Cannot replicate problem at this very moment.

Tgr added a comment.Oct 27 2015, 9:39 AM

I found http://stackoverflow.com/questions/33209454/adsense-resource-not-found-error-400ok, which is another person complaining about an intermittent 400 OK response showing up in Chrome. Notice that it was asked on 19 Oct. So perhaps this is some kind of intermittent bug in new versions of Chrome.

I have a fix for the 400 issue, that was just a stupid mistake in the thumbnail URL guessing code. There is a fallback for failed guesses, probably what happened is that people started getting the other error on the fallback requests (the guessing error itself has been live for a year or so, and normally due to the fallback it would only make image loading slightly slower).

Also bad URLs correctly report 400 Bad Request now. That message is sent by the server, including the text part; the OK must have been some small mistake in some caching or error handling logic which got fixed recently.

Tgr added a subscriber: Gilles.Oct 28 2015, 11:29 PM

@Krinkle that's probably unrelated. What configuration does wikitech use? That sounds a bit like T66554#687472. If you are still affected by the bug, can you click on the "report" button and copy the data here?

@Gilles would you be OK with disabling AJAX loading to see if that makes the problems go away? That would mean most information in MultimediaViewerNetworkPerformance goes missing.

Hi,

I could see the image (Bernini. "La tentación de St. Teresa") now very well.

Thank you.

@Gilles would you be OK with disabling AJAX loading to see if that makes the problems go away? That would mean most information in MultimediaViewerNetworkPerformance goes missing.

Sure thing, go ahead!

I would ask you to remove me from your mailing list. So far I have not seen
problems.
Thank you so much.

@Cumboto: If you'd like to remove yourself from the subscribers of this task, click "Edit Task" in the upper right section and remove your name from the CC field. Thanks!

Cumboto removed a subscriber: Cumboto.Oct 29 2015, 5:01 PM
Jdlrobson lowered the priority of this task from Unbreak Now! to High.Nov 3 2015, 6:39 PM
Jdlrobson added a subscriber: Jdlrobson.
Aklapper added subscribers: Blackjavad, StudiesWorld.

Some data (screen size, canvas size, image size, thumbnail size, etc) available in the T117672 testcase.

Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Nov 5 2015, 6:32 PM
Aklapper renamed this task from MediaViewer intermittent image loading errors (2015 Oct) to MediaViewer intermittent image loading errors (2015 Oct-Dec).Nov 30 2015, 9:46 AM
Restricted Application added a project: Commons. · View Herald TranscriptNov 30 2015, 9:46 AM

The first error is a duplicate of T108449.

zhuyifei1999 moved this task from Incoming to Backlog on the Commons board.Nov 30 2015, 11:18 AM

Thanks, Aklapper!

What are the next steps with this card? Could you add a checklist to the description of what's left to do?

Tgr added a comment.Dec 3 2015, 12:45 AM

What are the next steps with this card? Could you add a checklist to the description of what's left to do?

  • figure out what the hell is wrong
  • fix it

Not very helpful, I know.

Tgr updated the task description. (Show Details)Dec 3 2015, 12:46 AM
Tgr added a comment.Dec 3 2015, 12:54 AM

One possible set of next steps (of the "I can't think of anything better" kind) is to find a reporter who can still reproduce the issue, disable MediaViewer CORS image requests (probably just make imagePreloadingSupported and needsCrossOrigin in resources/mmv/provider/mmv.provider.Image.js always return false) and see if that affects the error. Then goto step 1 on the previous diagram.

In any case there is nothing that can be done before the deploy freeze ends.

do we know these error reports are still coming in?

Tgr added a comment.Dec 3 2015, 10:21 PM

They seem to, but with a significantly less frequency than initially (just search for "merged a task" in this page). It's hard to tell for sure because there is nothing really specific about the errors; you would see the same if e.g. you have a crappy internet connection and some requests time out.

Jdlrobson lowered the priority of this task from High to Medium.Dec 15 2015, 5:50 PM

What is the status of this? The first error describes an exactly like T108449: ERR_SPDY_PROTOCOL_ERROR on Commons files with Chrome and Avast (Declined). The second error is already fixed.

Tgr added a comment.Dec 31 2015, 5:42 PM

What is the status of this? The first error describes an exactly like T108449: ERR_SPDY_PROTOCOL_ERROR on Commons files with Chrome and Avast (Declined).

See the last comment on that bug.

Krinkle removed a subscriber: Krinkle.May 10 2016, 4:41 PM
Restricted Application added a subscriber: Poyekhali. · View Herald TranscriptMay 10 2016, 4:41 PM
MarkTraceur closed this task as Invalid.Apr 27 2017, 3:35 PM
MarkTraceur added a subscriber: MarkTraceur.

Based on the long gap between responses on this bug, I'm going to guess that it's no longer an issue - especially since seemingly none of the examples still cause problems (at least for me).

Jwpat7 added a subscriber: Jwpat7.EditedFeb 11 2019, 8:16 PM

Regarding the problem with an error screen appearing after clicking a small image (with message "Sorry, the file cannot be displayed" "There seems to be a technical issue"): This message occurs when I click on images on the page https://en.wikipedia.org/wiki/Dilution_refrigerator using browser "Chromium Version 71.0.3578.98 (Official Build) Built on Ubuntu , running on Ubuntu 18.04 (64-bit)".

I tried the advice in Tgr's comment of Oct 26 2015, 7:00 AM, which was: "...before clicking on a thumbnail, open the developer console (F12), copy this line and press Enter:"
mw.loader.using('mmv', function() { mw.mmv.provider.Image.prototype.imagePreloadingSupported = function() { return false; }; });

I pressed F12 on Dilution_refrigerator page, went back to this page, highlighted the line (the mw.loader...}); text), went back to the Dilution_refrigerator page, and pressed enter. Then F12 to close developer console, then clicked image, and got "Sorry...technical issue" error screen. (Large image seems to appear quite briefly - for perhaps a tenth to a half of a second - between clicking the inline image and the appearance of the error screen, or between clicking retry and the appearance of the error screen.) I also tried different orders (eg, highlighting the mw.loader...}); text before F12, clicking an image before closing developer console, etc) and also tried ^C and ^V to copy/paste the line; no help. (In short, it isn't clear to me what to do with the line once it's copied.) On one try images worked ok on the Dilution_refrigerator page, but I haven't been able to replicate that success in a dozen tries since. Image enlargement works ok on a half dozen other pages I tried before writing this complaint.

Tgr added a comment.Feb 12 2019, 12:14 AM

@Jwpat7 you need to refresh the page, then enter the code before opening any images in MediaViewer, then try opening an image. Apart from that what you do with the console doesn't matter (although if you leave it open there's a chance it gives you some useful error message when opening the image fails).

I have no idea what could cause errors on a single page only, other than some kind of transient network error.

Jwpat7 added a comment.EditedFeb 12 2019, 3:05 PM

@Jwpat7 you need to refresh the page, then enter the code before opening any images in MediaViewer, then try opening an image. Apart from that what you do with the console doesn't matter (although if you leave it open there's a chance it gives you some useful error message when opening the image fails).

...

Where, on the console, do I enter the line of code? The only entry box I see is labeled Filter. The larger code box at left side of console acts like read-only. If it isn't, where in that box is the mw.loader...}); text supposed to be added?

Note, MediaViewer continues to work ok (on all the pictures on the Dilution Refrig page) in the tab which I mentioned before as working for some reason. Duplicating that tab, in the new instance the error page appears. Refreshing (with ctrl-F5) in the duplicated tab apparently makes no difference.

[A few days later:] After a system restart, problem is gone & not replicable