Page MenuHomePhabricator

Banner impressions not updating on lutetium
Closed, ResolvedPublic

Description

New banner impressions are not appearing in the pgehres.bannerimpressions table on lutetium. The last entry was at 2015-10-19 22:15:00

select * from pgehres.bannerimpressions order by timestamp desc limit 20;

This is stopping us (and the German chapter) from getting test results, so should be fixed ASAP.

Event Timeline

Pcoombe created this task.Oct 20 2015, 3:15 PM
Pcoombe raised the priority of this task from to Unbreak Now!.
Pcoombe updated the task description. (Show Details)
Pcoombe added a project: Fundraising-Backlog.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 20 2015, 3:15 PM

@Jgreen
We stopped receiving beaconImpressions files at around 22:37:31 UTC, yesterday. Please let us know what you find, it's critical for FR-online... Thanks!

Confirmed broken. It looks like file replication stopped, or the upstream logs are not being generated.

awight added a comment.EditedOct 20 2015, 4:58 PM

So, looks like we'll have a permanent hole in the data, from 2015-10-10 22:15 to 2015-10-20 16:45. Sorry!

Data should be fine going forward.

Thanks for looking into that and fixing it so quickly!

I don't think that's the case, the log rotation script backs off if it
wasn't able to access the destination directory. So the first file rotated
today should contain all the data.

Pcoombe lowered the priority of this task from Unbreak Now! to High.Oct 20 2015, 5:55 PM

@awight @Jgreen Thanks for fixing! If it is possible to get the missing data backfilled, that would be really helpful (we have been running tests today). It's a lower priority though.

@Jgreen
Thanks for pointing that out! Confirmed that there is no hole in the data, the first new file contained 2015-10-19T22:15:01 through 2015-10-20T16:45:01.

Pcoombe closed this task as Resolved.Oct 21 2015, 3:12 PM
Pcoombe claimed this task.

Great, I confirmed it too. I've sent WMDE the numbers they missed. Thanks for the quick resolution!

K4-713 set Security to None.
mmodell removed a subscriber: awight.Jun 22 2017, 9:36 PM