Circular dependency kills "Add blocking task" dialog
Closed, ResolvedPublic

Description

Steps to reproduce:

  • Open bug T38591
  • Note that this bug blocks T34482
  • Open the add blocking task dialog, add T34482 and save

Infinite hang, with a greyed page.

Whether or not this is a valid thing to do, protect against infinite looping in the UI.

awight created this task.Oct 21 2015, 8:32 AM
awight updated the task description. (Show Details)
awight raised the priority of this task from to Needs Triage.
awight added a project: Phabricator.
awight added a subscriber: awight.
Restricted Application added subscribers: scfc, Aklapper. · View Herald TranscriptOct 21 2015, 8:32 AM

Confirming on Firefox 41.
Open "Blocked By" dialog, paste T34482 in the text field, click "Select" once it is shown, click "Save 'Blocked By' Tasks" at the bottom.

Browser sends a HTTP 200 which turns into a 503:

Request: POST http://phabricator.wikimedia.org/search/attach/PHID-TASK-p5nqnkahr2g5sm6kpzi4/TASK/blocks/, from 10.64.32.134 via cp1057 cp1057 ([10.64.32.134]:80), Varnish XID 975093205
Forwarded for: 12.345.67.890, 10.64.32.134
Error: 503, Service Unavailable at Wed, 21 Oct 2015 08:39:27 GMT

Aklapper triaged this task as Lowest priority.Feb 18 2016, 11:45 AM
Restricted Application added a subscriber: Luke081515. · View Herald TranscriptFeb 18 2016, 11:45 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptJul 2 2016, 7:58 PM

This is likely fixed upstream: https://secure.phabricator.com/T6815

(We've always detected and prevented this, the error dialog just got lost in some cases for a while.)

Aklapper closed this task as Resolved.Jul 4 2016, 5:05 PM
Aklapper claimed this task.

Thanks epriestley!

Confirming that this is resolved.

The testcase provided in this task now triggers a dialog:

Circular Dependency
You can not create that relationship because it would create a circular dependency:
T38591: Use the Translate extension in CentralNotice (tracking) → T34482: CentralNotice needs a better way to manage shared messages → T38591: Use the Translate extension in CentralNotice (tracking)