Page MenuHomePhabricator

Cannot edit any image because while trying to edit an existing image, instead of "Apply Changes", there is now "Upload" button
Closed, ResolvedPublic1 Estimated Story Points

Description

Steps to reproduce:
1.Insert an image
2.Save the page
3.Reopen the page with VE
4.Select an already added image
5.Click on Edit from the context menu

Observe that, in the media settings dialog the button on the top right is not "Apply Changes" anymore, it's "Upload"
So if you make any changes to it , its not anymore applicable to that image

Event Timeline

Ryasmeen raised the priority of this task from to Needs Triage.
Ryasmeen updated the task description. (Show Details)
Ryasmeen added a project: VisualEditor.
Ryasmeen added a subscriber: Ryasmeen.
Ryasmeen set Security to None.

Like with T116219, this only happens the first time you open the dialog.

Change 248083 had a related patch set uploaded (by Bartosz Dziewoński):
ve.ui.MWMediaDialog: Move upload booklet init further up

https://gerrit.wikimedia.org/r/248083

Change 248083 merged by jenkins-bot:
ve.ui.MWMediaDialog: Move upload booklet init further up

https://gerrit.wikimedia.org/r/248083

Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF edited a custom field.

Change 248247 had a related patch set uploaded (by Bartosz Dziewoński):
ve.ui.MWMediaDialog: Move upload booklet init further up

https://gerrit.wikimedia.org/r/248247

Change 248247 merged by jenkins-bot:
ve.ui.MWMediaDialog: Move upload booklet init further up

https://gerrit.wikimedia.org/r/248247