Page MenuHomePhabricator

Third QuickSurvey for reader segmentation research - run multiple choice survey
Closed, ResolvedPublic1 Story Points

Description

array(
		"@description"=> "description of the survey",
		"description" => "Reader-segmentation-1-description", // (blank)

		"@link"=> "external link to the survey (must be https)",
		"link"=> "Reader-segmentation-3-link", //https://docs.google.com/forms/d/171PLghcRKF5ir6hbexBv_6CnxchikDprS_GHxgylhKg/viewform

		"@question"=> "survey question message key",
		"question"=> "Reader-segmentation-3-message", // Answer three questions and help us improve Wikipedia.

		"@privacyPolicy"=> "message key for privacy policy. May contain links.",
		"privacyPolicy"=> "Reader-segmentation-1-privacy",  // Survey data handled by a third party. [https://wikimediafoundation.org/wiki/Survey_Privacy_Statement Privacy].

		"@coverage"=> "percentage of users that will see the survey",

		"coverage"=> "0.00005", // 5 out of 100K (0.005%)

		"@platform"=> "for each platform (desktop, mobile), which version of it is targeted (stable, beta, alpha)",
		"platform"=> array(
			"desktop"=> ["stable"],
			"mobile"=> ["stable"]
		)
	)

Event Timeline

atgo created this task.Oct 23 2015, 8:48 PM
atgo assigned this task to leila.
atgo raised the priority of this task from to Needs Triage.
atgo updated the task description. (Show Details)
atgo added subscribers: gpaumier, ellery, Aklapper and 2 others.
leila added a comment.Oct 27 2015, 8:14 PM

@atgo Is there a limit on the number of tags we can show to the survey participant? Also, do we have a sample of QuickSurvey mock-ups I can look at before confirming that all blockers are listed correctly for the current task?

@atgo: awesome!

There's some minor vertical alignment or padding issue with the text of the buttons that probably needs to be fixed. Also, the div doesn't seem to extend enough to wrap the 4 tags.

atgo added a comment.Oct 28 2015, 3:54 PM

@dario that's captured here: T112982

leila renamed this task from Second QuickSurvey for reader segmentation research - run multiple choice survey to Third QuickSurvey for reader segmentation research - run multiple choice survey.Nov 20 2015, 5:09 AM
leila set Security to None.
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 20 2015, 5:09 AM
leila updated the task description. (Show Details)Nov 20 2015, 7:10 PM
dr0ptp4kt moved this task from Backlog to Next Up on the Reading-Admin board.Nov 21 2015, 12:14 AM
leila added a subscriber: jhobs.

@jhobs If we want the survey to be deployed tomorrow, what is the deadline for finalizing the information in the description. We're actively working on them and should be able to finalize them in the next 3 hours.

leila updated the task description. (Show Details)Nov 23 2015, 6:19 PM
leila updated the task description. (Show Details)
leila updated the task description. (Show Details)
jhobs added a comment.EditedNov 23 2015, 6:35 PM

@jhobs If we want the survey to be deployed tomorrow, what is the deadline for finalizing the information in the description. We're actively working on them and should be able to finalize them in the next 3 hours.

Sorry, but this will not be able to be deployed tomorrow, period. We're listing the bug where no EventLogging table was created by the first survey (T119152) as a blocker for any new surveys until it is investigated, and there's just no way it could be diagnosed, fixed, merged, and deployed by tomorrow's SWAT. In addition, it's much better for us to not SWAT anything right before a holiday and we're more likely to get less skewed results afterwards. The earliest this could be deployed would be Monday, November 30th.

atgo added a comment.Nov 23 2015, 6:53 PM

We shouldn't run this during the Fundraiser, so it looks like it will have
to wait until January.

leila added a comment.Nov 23 2015, 7:09 PM

@jhobs, what @atgo said about the timing. If we don't do it this week, it seems it will be deferred to Q3 because of Fundraising.

Re T119152, that's not a blocker for this task. We don't need EL tables and responses for this specific survey. With this information, can we make this survey happen tomorrow?

Ok, ignore my previous comment then. For history's sake, we had an IRC discussion that led to the conclusion that we will be able to run this survey in Q2 by SWAT deploying tomorrow morning.

jhobs triaged this task as Normal priority.Nov 23 2015, 7:27 PM
jhobs edited a custom field.

Change 254908 had a related patch set uploaded (by Jhobs):
[WIP] Third QuickSurveys external survey

https://gerrit.wikimedia.org/r/254908

leila updated the task description. (Show Details)Nov 23 2015, 10:42 PM
leila reassigned this task from leila to jhobs.Nov 24 2015, 5:51 AM
leila updated the task description. (Show Details)
leila added a subscriber: leila.Nov 24 2015, 5:55 AM

@jhobs the array in Description is ready. Please go ahead with it. One note about the sampling rate: I kept the description based on the definition of the first survey, and not the second (not sure which one is the way we want to continue using). We need 5 out of 100K. :-)

jhobs updated the task description. (Show Details)Nov 24 2015, 3:35 PM

Change 254908 merged by jenkins-bot:
Third QuickSurveys external survey

https://gerrit.wikimedia.org/r/254908

Survey is live. It will be ended on Monday Nov. 30th.

@jhobs, while in an internal thread we are figuring out the sources of very few number of responses, can you multiply Coverage by 100, so change the value from 0.00005 to 0.005? I'll update the email thread, too.

The patch has been deployed.

Change 255448 had a related patch set uploaded (by Jhobs):
Disable QuickSurveys reader segmentation survey

https://gerrit.wikimedia.org/r/255448

The patch to disable this survey has been scheduled for Monday's morning SWAT (8-9am PST).

Change 255448 merged by jenkins-bot:
Disable QuickSurveys reader segmentation survey

https://gerrit.wikimedia.org/r/255448

phuedx added a subscriber: phuedx.Nov 30 2015, 7:24 PM

Confirmed that the wgEnabledQuickSurveys config variable isn't present on enwiki.

phuedx closed this task as Resolved.Nov 30 2015, 7:24 PM