Page MenuHomePhabricator

Link education pop-up appears at the start of every editing session, not just once per user
Closed, ResolvedPublic1 Story Points

Description

From {T108620#1765749}

Steps to reproduce:

  1. Go to a wiki with these prompts enabled (this has been reproduced so far on meta, enwiki, officewiki, and enwikivoyage).
  2. Open a page. Click in the toolbar to make a link. Read and close the educational pop-up.
  3. Save the page.
  4. Refresh the page (maybe not necessary?)
  5. Open it again.
  6. See the blue dot on the link item in the toolbar again.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : wmf/1.27.0-wmf.4Register the preference to hide education popups
mediawiki/extensions/VisualEditor : masterRegister the preference to hide education popups

Event Timeline

Whatamidoing-WMF raised the priority of this task from to Needs Triage.
Whatamidoing-WMF updated the task description. (Show Details)
Whatamidoing-WMF added a subscriber: Whatamidoing-WMF.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 29 2015, 7:34 PM

This happened on Beta for me as well, thought this is a Beta specific issue. Seems like its not.

For me, the blue-dot re-appears after an idle time on the same session.

Also, was able to reproduce in en.wiki just now

Change 249949 had a related patch set uploaded (by Alex Monk):
Register the preference to hide education popups

https://gerrit.wikimedia.org/r/249949

Elitre added a subscriber: Elitre.Oct 30 2015, 10:21 AM

Yeah, I'm also seeing them on en.wp now.
Another thing, since I'm here: when I close the pop-up, I don't really expect having to click again on the button to use the link/cite tool.

Change 249949 merged by jenkins-bot:
Register the preference to hide education popups

https://gerrit.wikimedia.org/r/249949

(Yet another thing... on Office wiki I think I see the link popup but not the blue dot?)

Change 249998 had a related patch set uploaded (by Alex Monk):
Register the preference to hide education popups

https://gerrit.wikimedia.org/r/249998

Change 249998 merged by jenkins-bot:
Register the preference to hide education popups

https://gerrit.wikimedia.org/r/249998

Commit is deployed, seems to have fixed the issue. Not closing this because I'm planning to investigate @Elitre's officewiki issue when I get back later.

@Elitre: Can you still reproduce that issue? I saw the blue dot...

Jdforrester-WMF closed this task as Resolved.Oct 31 2015, 12:08 AM
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF edited a custom field.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Neil_P._Quinn_WMF renamed this task from Link education pop-up appears at the start of every editing session, not just once per user, at Meta to Link education pop-up appears at the start of every editing session, not just once per user.Oct 31 2015, 11:17 PM
Neil_P._Quinn_WMF reopened this task as Open.
Neil_P._Quinn_WMF updated the task description. (Show Details)

I just saw this on English Wikipedia. Doesn't seem to be resolved.

Neil_P._Quinn_WMF closed this task as Resolved.Oct 31 2015, 11:24 PM

Actually, that might just have been my first time seeing it on enwiki. It's likely fixed after all.