Page MenuHomePhabricator

Globalcollect recurring job needs fixes for Civi 4.6
Closed, ResolvedPublic

Description

PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown [error]
column 'civicrm_contribution_recur.next_sched_contribution' in 'where 
clause': SELECT * FROM civicrm_contribution_recur
WHERE
    civicrm_contribution_recur.next_sched_contribution BETWEEN :start
AND :end
    AND civicrm_contribution_recur.trxn_id LIKE 'RECURRING
GLOBALCOLLECT%'
    AND ( civicrm_contribution_recur.end_date IS NULL ) 
    AND civicrm_contribution_recur.contribution_status_id =
:status_id
LIMIT 1; Array
(
    [:start] => 2015-10-16 00:00:00
    [:end] => 2015-10-30 23:59:59
    [:status_id] => 1
)
 in wmf_civicrm_get_next_sched_contribution() (line 232 of
/X/sites/all/modules/wmf_civicrm/recurring.inc).
PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column `civicrm_contribution_recur.next_sched_contribution` in "where clause": SELECT * FROM civicrm_contribution_recur
WHERE
    civicrm_contribution_recur.next_sched_contribution BETWEEN :start AND :end
    AND civicrm_contribution_recur.trxn_id LIKE 'RECURRING GLOBALCOLLECT%'
    AND ( civicrm_contribution_recur.end_date IS NULL ) 
    AND civicrm_contribution_recur.contribution_status_id = :status_id
LIMIT 1; Array
(
    [:start] => 2015-10-16 00:00:00
    [:end] => 2015-10-30 23:59:59
    [:status_id] => 1
)
 in wmf_civicrm_get_next_sched_contribution() (line 232 of /X/sites/all/modules/wmf_civicrm/recurring.inc).

Event Timeline

awight created this task.Oct 30 2015, 2:02 AM
awight raised the priority of this task from to Unbreak Now!.
awight updated the task description. (Show Details)
awight added subscribers: gerritbot, awight, Aklapper.

19:01 < eileen> looks like we need to replace all instances of next_sched_contribution with next_sched_contribution_date

awight closed this task as Resolved.Oct 30 2015, 3:02 AM
awight claimed this task.

Confirmed working.

DStrine set Security to None.
mmodell removed a subscriber: awight.Jun 22 2017, 9:51 PM
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptJun 22 2017, 9:51 PM