Page MenuHomePhabricator

"Clear all history" should also implicitly clear tabs and backstacks.
Closed, ResolvedPublic1 Story Points

Description

Description

If you navigate through the Wikipedia app and, at the end of the experience (;)), you delete the history of visited pages, another one (or you) is still able to go through the last visited pages of the session (since the last time the app was killed). Compared with the missing "Exit" menu, the "delete history" function should delete the stack of opened pages since the last restart, too.

Steps to reproduce

  1. Open the app
  2. Navigate through some pages
  3. Go to the history and delete it
  4. Press "back"
  5. Press "back" again (you can do it several times, depends on how many pages you opened before)

Expected results

The app should close

Actual results

You can navigate through all pages opened since the last time the app was opened.

Environments observed

App version: doesn't matter / 2.1.133-r
Android OS versions: 5.1
Device model: HTC One M9
Device language: german / english

Event Timeline

Florian created this task.Nov 1 2015, 7:10 PM
Florian raised the priority of this task from to Needs Triage.
Florian updated the task description. (Show Details)
Florian added a subscriber: Florian.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 1 2015, 7:10 PM

I have a correction to the "Actual results" as described above

The text under "Actual results" says that "You can navigate through all pages opened since the last time the app was opened."

Acutally, you can navigate through all pages that have been opened since installation of the WIKI-app (or since the WIKI-app-data were deleted by the phone's own functionality "settings->app-> .... clear app data"

As a first check to verify this:
After a restart of the mobile phone, all the pages of the deleted history can still be displayed by repeatedly pressing "back".

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 11 2015, 8:12 PM
Dbrant renamed this task from "Clear history" doesn't delete the session history to "Clear all history" should also implicitly clear tabs and backstacks..Nov 12 2015, 7:09 PM
Dbrant moved this task from Product Backlog to Next Sprint on the Wikipedia-Android-App-Backlog board.
MBinder_WMF edited a custom field.Nov 20 2015, 6:36 PM
Dbrant claimed this task.Dec 1 2015, 8:44 PM
Dbrant moved this task from To Do to Doing on the Mobile-App-Android-Sprint-71-Lutetium board.

Change 256340 had a related patch set uploaded (by Dbrant):
Clear all tabs when clearing history.

https://gerrit.wikimedia.org/r/256340

Change 256340 merged by jenkins-bot:
Clear all tabs when clearing history.

https://gerrit.wikimedia.org/r/256340

Dbrant closed this task as Resolved.Dec 7 2015, 4:10 PM