Page MenuHomePhabricator

TemplateData editor broken at eo.wikipedia.org due to local Common.css being broken
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Open https://eo.wikipedia.org/w/index.php?title=Ŝablono:Mankas_fonto/dokumentado&action=edit
  2. Wonder why the buttons for the TemplateData editor look strange.
  3. Click "Manage TemplateData".
  4. See error, "something went wrong", at the bottom of the page.

Event Timeline

Whatamidoing-WMF raised the priority of this task from to Needs Triage.
Whatamidoing-WMF updated the task description. (Show Details)
Whatamidoing-WMF added a project: TemplateData.
Whatamidoing-WMF added a subscriber: Whatamidoing-WMF.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptNov 4 2015, 6:58 PM
Elitre added a subscriber: Elitre.Nov 4 2015, 7:05 PM

The second time I clicked on the link, everything looked fine for me?

matmarex added a subscriber: matmarex.

Hah, yeah, I experienced the same thing as @Elitre. The first time it looked as if none of the OOjs UI styles were loaded (but all the JavaScript code was loaded and working). It was probably intermittent, but maybe somebody has any idea of recent ResourceLoader changes that could result in bugs like this?

Elitre added a comment.Nov 4 2015, 7:40 PM

(Or something in that's site common.js that messes stuff up?)

Krinkle added a subscriber: Krinkle.EditedNov 4 2015, 7:58 PM

I can consistently reproduce this by running localStorage.clear(); and then refreshing the page.

This is not caused by a change in ResourceLoader, however.

Rather, it's due to the site stylesheet having broken a syntax error in MediaWiki:Vector.css which broke some of the other stylesheets loaded in the same batch. Without cache, the time between batches is longer so they end up in a separate batch. When loading from cache they usually end up in the same batch.

Fixed in eo.wikipedia.org Revision #5789263.

See also T112552.

Krinkle set Security to None.
Jdforrester-WMF renamed this task from TemplateData editor appears to be broken at eo.wikipedia.org to TemplateData editor broken at eo.wikipedia.org due to local Common.css being broken.Nov 4 2015, 9:11 PM
Jdforrester-WMF closed this task as Resolved.
Jdforrester-WMF assigned this task to Krinkle.
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF moved this task from Backlog to Doing on the TemplateData board.Jan 15 2016, 9:26 PM